Our Community is 705,000 Strong. Join Us.


Engine cut off only whene I wait at red light


david123go
05-11-2008, 05:00 PM
With my ford probe 94 , 4 2L auto AC .My engine cut off whene I wait at a red light after a few minutes afther a go whene the car temperature is normal .... The oil indicator comme down just before the cut off ....The car restart well.....(someting smell strange). Now whene I wait at a red light I put my car at ``N`` the RPM is higher .....my blug and injector are new and clean......and the oil level is ok....Thank you for your help

DragonLord3688
07-31-2008, 09:51 AM
Your alternator could be faulty

Maybe your idle control sensor could be one of the problems?

You're saying the car turns itself back on after the engine cuts COMPLETELY, off?

Scrapper
07-31-2008, 11:15 AM
i seen this before on my sister can 93 probe..the iac. was bad..

Texas is Hot
07-31-2008, 12:30 PM
Check your emissions sensors main ones are the idle control and the vent valve from gas tank. look in your auto repair manuel for location and how to test. your vent valve on gas tank are normally closed. if you remove it you can check it by blowing air through them, if air blows through its bad.

hlndr32
08-25-2008, 04:52 PM
the same thing happened to me with one of my probes... try checking the mass air sensor.... the flap sometimes sticks and will kill ur car.... u can see scrape marks on the inside of the housing where it could be hitting

crate10155
02-06-2009, 03:24 AM
I think I've been having a similar problem. I have a 2.0 with manual transmission. When waiting at red lights the idle will drop really low, sometimes stall. I haven't cleaned my MAF but I put some compression restore additive in when I changed the oil. I noticed an improvement, but I will get some MAF cleaner next time I'm at Autozone.

Add your comment to this topic!