Our Community is 705,000 Strong. Join Us.


98 chevy z71 Transmission not shifting, Speedometer at zero, and Abs light on!


quepasa69
05-06-2008, 09:55 PM
I have a 1998 chevy z71 with 149,300 miles with an automatic transmission. Today after I turned a corner at about 10-15mph I felt the transmission jerk, then the abs light came on, the speedometer went to zero, and then the tranny felt like it was slipping. It would run about 1st or 2nd gear and kept running high rpm's and would not shift. 45 mph is about all it would do. Sometimes I can shut off the motor, then start and it works just fine. Now its doing it constant. Talked to a mechanic after it was working, said maybe neutral switch was causing it but wasn't sure. Any help is appreciated!

Blue Bowtie
05-06-2008, 10:52 PM
Have the PCM scanned for transmission trouble codes. Check the electrical connector on the right side of the trans. Verify fluid level and condition. Does the reverse range work? Any unusual noises? If the filter is hanging loose, it might be a cause, especially after cornering. .

cfrank2
05-09-2008, 11:20 AM
All of your problems are leading me to a speed sensor.

j cAT
05-09-2008, 06:10 PM
All of your problems are leading me to a speed sensor.

i believe the transmission speed sensor/connector/wiring is bad..speedometer is generated from this transmission sensor..with no output this will cause your problems....

knucklebuster69
08-13-2009, 12:08 AM
Sounds like the speed sensor...It is a good place to start! Good luck.:)

Jeremy-WI
08-13-2009, 06:35 AM
Most likely cause is a bad ignition switch, some of the contacts can get bad an not supply power(or enough power) to the trans. When this happens you have no PRNDL, no tach, no speedo, no shifting unless manually shifted, and third gear starts unless shifted manually. The check engine light should be on with up to six codes for trans solenoid electrical.

If you have the light duty 4L60E you will start in third, with the heavy duty 4L80E you will have second

Add your comment to this topic!