Our Community is 705,000 Strong. Join Us.


94 van 2500 runs rough after useing lucas oil


floor layer
05-01-2008, 12:45 AM
Van has 156k and runs strong. Put in a quart of lucas oil and drove 120 miles and started to run rough at idle. Harder to start. after two days it would not idle but ran good on the freeway.A day later seems like its running on 4 cylinders under a load. Changed the ecm on the back of the throttle body and helped a little. The pvc rattles at idle and has a loud sucking air sound in the air cleaner. pulled the pvc hose off the manifold and it ran smoother, started easier. computer problem?

alloro
05-01-2008, 08:30 AM
Sounds like your crankcase breather filter needs a good cleaning or replacement. The Lucas probably helped seal up the rings and cut down on the blow by. Now the crankcase is starving for air and with a clogged breather element, it's not getting it. If I'm correct, removing the oil filler cap to let air in will smoothen the engine out.

floor layer
05-01-2008, 05:25 PM
I removed the oil cap and still runs bad. Does a coil go bad and yet still send a lower voltage spark? Please help

alloro
05-02-2008, 08:11 AM
If you pulled the pcv hose off the manifold and it ran smoother, then opening the oil filler cap would've done the same thing. So pulling the pcv hose was just coincidence. Did you check for trouble codes, if so, what are they?

floor layer
05-06-2008, 11:20 AM
Found the problem. When the egr goes bad the valve stays open which forces the exhaust into the manifold and wont let it idle and hard to start. The new egr makes the engine run smooth again. Hope this will help others

Add your comment to this topic!