'04 Tacoma TRD low rpm Tapping Noise


2240norman
04-24-2008, 10:07 PM
Hello all,
I recently traded my gas guzzlin Z71 for a more fuel effecient 04 tacoma 2 wheel drive TRD Prerunner. Up until now i have been totally satisfied with it,
Yesterday i noticed a tapping noise a low idle. At normal operating temperature, while still in gear sitting still and the truck is idling at 650 rpm's and once you turn the AC on the
additional load brings the rpm's to 630 ( I know this cause i have a scan gauge tool) well back to the problem. You start to hear a moderate tapping noise ( almost like a lifter or something in the valvetrain) now when the AC compessor cycles off, the rpms increase some and the tapping goes away. So obviously when the engine is under a load is when you hear the tapping. At first, I thought it had something to do with the Transmission because i only heard it when it was in gear, but quickly realized it was the load on the engine that was iniating the noise. I bought the truck with 88k on it and now has 94k, everything else works great, no engine lights, no power loss, just changed the oil (used exactly 5.5qts for the 3.4L) I do plan on replacing timing belt very soon. Does anyone have any suggestions as to what this problem can be? thanks in advance for any help.

2240norman
05-04-2008, 03:17 PM
well i think i figured out my problem. I spoke with my mechanic friend and he gathered that the noise is coming from my timing belt tensioner which does make sense because the truck does have 94,000 miles on it and needs to have all that replaced in which i have been planning to change the timing belt, water pump, and pulleys all before it hit 100k. so thanks for reading and maybe this can help somebody else.

Flash75
05-07-2008, 06:13 AM
Thanks for the information.

Clifton

2240norman
08-25-2008, 10:54 PM
well, truck currently has 98k on it and i haven't yet replaced timing belt and all the other things i mentioned. It still has that faint tapping noise, but hasn't gotten worse or experienced any power loss. I had another friend say though instead of it being a bad belt tensioner. The tapping noise i hear is actually the belt itself flopping against a close spot on the timing cover. I don't know, i plan on taking the timing cover off to confirm that and will let yall know.

4Wheel
08-26-2008, 09:03 AM
If it is ANYTHING to do with the timing belt R&R the belt now!
If the tensioner is lose the chance for jumping a tooth is high.

whosbaddad
08-26-2008, 01:59 PM
:banghead:

Had the same small noise on my 2002 tacoma 2.7
lots of tlc thru the years and 70,000 miles
harmonic balancer has broken loose and tore up the crank
what to do now?

Add your comment to this topic!