Our Community is 705,000 Strong. Join Us.


Rough Idle


madmonk210
04-24-2008, 02:26 AM
Has anyone had a 2007 canyon with 6000 miles on it that neaded the head replaced and then still runs rough? I've brought it in to the dealer and they can't fix the rough idle for some reason!! I will go to the store in the morning and get coffee and gas and start up my truck and POP! POP! RATTLE! RATTLE! ANDTHEN DIES! and I start it agin and it runs fine. I keep telling the dealer that the timing is off, because accelerating up a hill I start hearing a rattling chain noise. Just trying to figure out if anyone else has had a problem like this.

Miles

NONo443
05-24-2008, 01:11 PM
If you can, go to another dealer to get a second opinion. My guess (just off the top of my head), is that you'll need a PCM reflash. Well, either that, or they did something wrong while putting the new head on.

Tuffdrvr88
05-25-2008, 02:28 PM
Yea he is right see if you can get the memory reflashed, thats the only way to change/correct the timing these days. You shouldn't have any problems that early, my props to you for not killing anyone lol.

sdogg0
10-01-2008, 07:34 PM
I have replaced a few heads on these engines. You can severley screw up the timing if the proper chain holder and procedure is not used. The concern for these heads is only a light miss at idle, only extreme cases will they completley quit on you. Is the CEL light on, if it is I suspect they possible incorrectly timed the engine during the reassembly process.

Add your comment to this topic!