93 corsica tcc disconnect location???


paul_j
03-15-2008, 04:10 PM
mileage:178,000. TH125. I've read several threads on the tcc and I have the exact problem. It's been happening for over a year. I looked all over the trans and cannot find the connection to disable it. There's no connections on the right transaxle.

The only connections on top of the trans were the computer on the driver side and the speedometer on the pasenger side. There are several electrical connections behind the right strut (2 of the 4 connections are 4 prong) that I don't know what they are or where they're going. They appear to be part of the computer(??).

Thanks for any help!!!

bushmstr02
03-22-2008, 08:00 PM
I'm not trying to hyjack your forum, but I figure you may have the same problems !

I'm having alot of trouble with this too ! I have read alot on here and other sites about this and i'm still confused about it. I found and changed my speed sensor and that didn't fix it , so it has to be the tcc solenoid , I think ! The big problem I am having is the part they gave me at the auto parts store looks nothing like what I find on my car ( 92 Corsica 6 cyl ). Under the air breather I only find one thing which is an electrical plug and when I pull it off it has four prongs on it with four wires coming out of it ( ??? ). The auto parts store (AZ) had no clue what I was talking about and the other ( AdvA ) gave me this :Automotive Transmission Control Solenoid Automotive Transmission Control Solenoid Hopefully that pic will show up . That's not what I got on my car ! That says it is an Automotive Transmission Control Solenoid , is that the same thing as a TCC ? TCC means torque clutch control solenoid , right ? I've looked online and can't find anyone that carries a TCC solenoid ! It has been doing this for over a year and I don't know what else to do , HELP ! I seen where someone said you had to splice it into the old wires , but the problem with that is there is four wires and the part only has two wires with like some kind of conductor types things on it . I know I need to change my ingnition coil packs also , one of them has gone bad . What mine is doing is :
coming to a stop it does a hard shift down into first
it shudders occasionally and has shut off once or twice
put it back in gear does fine for months, but still down shifts rough
Today after driving it for a couple of hours I was coming to a stop and it started making a noise kind of like when you hold your fingers on a fan while it's turning . It seemed really weak in power and shifted weird , stopped doing it soon after and when I almost got home it did it again . I let it sit and drove it again , just fine ! This is driving me crazy ! Can anyone tell me where to find the part , how to change it , and if i'm looking at the right part on my car ?

bushmstr02
03-22-2008, 08:02 PM
http://http://www.partsamerica.com/ProductDetail.aspx?MfrCode=BOR&MfrPartNumber=S9814&PartType=424&PTSet=A
This what I was given !

bushmstr02
03-27-2008, 01:55 PM
I talked to a mechanic today and I was looking at the right plug ( 4 prong plug with four wires on the front side of tranny on driver side under the air cleaner ) . He said the transmission had to come out ($500-$600) to actually change it because it can only be replaced by removing the tranny because it is attached to the inside of tranny . He said to just unplug it , he said he just cuts the pink wire that goes to it and never has any more problems out of them . He said it won't hurt a thing to do this , you just won't get lock up on the torque converter . I'm going to cut it and i'll let you know how it goes , he also says that there is a switch on the brake pedal that goes bad and sometimes replacing that will fix it .

bushmstr02
03-29-2008, 04:25 PM
It didn't fix it ! ???????

Add your comment to this topic!