Doesn't Anyone Answer These???


Mauinix
01-23-2008, 02:27 PM
I am beginning to have multiple electrical issues. I believe my heater core has quite working, but the relay continues to cycle constantly, inside the dashboard area, and I have no heat at all. It's very annoying to say the least. Anyway, I've also been receiving noise shorts over my radio, until the point that I have to shut it off, completely! My CD player cannot be heard at all, but appears to be working. Does anyone know if there is a common denominator or can you just reply with any help with any of the above issues??? I would appreciate it...

smplyred
04-10-2008, 04:28 PM
I was having an issue like that with the CD player that was already installed when I got the car. The CD player portion didn't work. Once I installed a brand new CD player...I haven't had the problem since.

Towncar
04-16-2008, 04:04 PM
I have no idea why I haven't see this post sooner.. I don't have a Mark but I normally browse all the Lincoln forums.. :banghead: sorry.

I am beginning to have multiple electrical issues.

Yes, these are multiple issues, not related.

The Heater problem:
The way you describe this one, it sounds like the Blend Door Actuator has broken. This is a common issue. Parts are relatively cheap compared to the labor. On my Town Car the whole dash panel needs to be moved a bit in order to get at the BDA. I can look up the process for your's if you like. Some folks found a way to manipulate the Door manually and left it at that.

The Radio problem:
This one needs further diagnosis. If you have HU removal tools you should pull the HU out, then re-seat it once or twice to make sure the connectors are contacting correctly; however, the 'pop' you hear is most likely a high voltage discharge.. not necessarily related to the stereo system. You might have a coil leaking voltage, or possibly a shorting Spark Plug Wire.
Also, after you prove the Ignition system isn't at fault, your Amp might be the next thing to consider, then finally.. your speakers might be shot.

Goddard007
04-22-2008, 11:18 AM
your coolant level affects heating as well. Atleast it did on my 97 lsc.

Add your comment to this topic!