Sony Xplod Amp question???


Ultimateone
10-09-2001, 12:18 PM
Today when I started my car, I noticed the over current light was on and my subs were not running at all. Please can anyone help because all of the Circuit Citys guys are morons with no answers.
Thanks

Tireburner
10-10-2001, 02:08 PM
The "over current" light, or "thermal protection" light will come on in amplifiers for a couple of real basic reasons.

Too much resistance to ground

Improper guage wires for power and/or ground

Running the amp in a warm environment (little venting) for extended periods of time

Having the ohm rating exceeded (too low) out to the speakers.

I think # 1 is probably your best bet.

On another note... I have had more problems with Sony audio products than I care to mention... including tons of amps (not the xplode though) going thermal.. so it could be the amp.

Ultimateone
10-10-2001, 02:41 PM
Its not the wires, I hav had it running for 5 months so far, but what exactly do you mean by ground resistance?

Tireburner
10-10-2001, 02:50 PM
Resistance in it's simplest form is that the amp (or other accessory) is not getting enough ground. You will show 12-13 volts at the unit doing a voltage test. But when you put a meter with one lead to the ground of the battery and the other to the amp. you will see a high resistance value. High resistance causes lack of current (amperage) (not voltage). Amps need a lot of current to operate properly.

Most installers use a seat belt bolt to ground the amp. This is okay, as long as they scraped all the paint from the body around where the ring tongue (the ground ring) touches the body. Unfortuanately most don't scrape the paint. This will cause the system to work for a while, then stop, or work intermittently.

Ultimateone
10-11-2001, 09:43 PM
Finally got someone to look at it, and the amp was totally smoked, I dont even know how but it was gone, so I had to get a new amp after only 5 months!

Tireburner
10-12-2001, 07:21 AM
That's bad news. Did you get Sony to replace under warranty?

Speaking from personal experience, I would avoid Sony products (except cam corders) in the future. There are a ton of excellent products out there in the same price range that have far better quality. I have had so many Sony failures I refuse to install them any more.

Ultimateone
10-12-2001, 12:10 PM
They said it would cost like 40 to send it to Sony and whatever the cost would be, plus they would have it for weeks or even a month, and I couldnt handle being without my stereo. So I purchased a Bazooka Monoblock Sub, and bridged it for my 2 subs....well it didnt even sound as good as the Sony...so Im going to get a Kenwood Excelon or Xtant amp today..whew!

Tireburner
10-12-2001, 12:34 PM
I haven't been able to damage my 3 Kenwood amps. I have had them for 7 years now.

ngsm13
02-18-2005, 01:46 AM
Personally i think you are all dummies!!!! peace

NG

;) ;) ;)

curtis73
02-18-2005, 02:38 AM
Here's an intersting link. This list is compiled by some of the greatest minds in electronics engineering and (with a few exceptions) it is widely accepted as near gospel truth.

its a list of bad, acceptable, and excellent mobile audio brand names as far as quality, reliability, and disregarding price, looks, and fancy neon. You'll be surprised at what is good and what isn't. For instance, one of the best on the market is also one of the cheapest; USAcoustics. They build their own guts and put them in cheap, non-flashy cases. They don't waste their money on bling, instead they just build a quality product.

Just thought I'd post since Sony came up in the not-so-good realm and you're looking to buy new stuff.

http://www.clubknowledge.com/Car_Audio_FAQ/?t11

curtis73
02-18-2005, 02:43 AM
I haven't been able to damage my 3 Kenwood amps. I have had them for 7 years now.

Its funny you mention that. I have a Kenwood 80w x 2 amp that I bought second hand in 1992 that is still alive and kicking driving two 6x9s in my SS. That amp has been in three different cars of mine and at least one car from the previous owner, has been used bridged as a sub amp, driven lightly as a full-range 6x9 power source, and absolutely abused when I ran it as my tweeter amp in my SPL car. At the best estimate, that Kenwood amp is at least 13 years old. If I looked hard enough I'm sure I could find a build date, but I'm afraid to touch it... it might dissolve or something :)

balls_to_the_wall
02-18-2005, 11:41 AM
The Link wouldn't work for me....

ngsm13
02-18-2005, 12:09 PM
HAHAHAHAHAH!!!!

Did you guys see what I did...this was the oldest post in the forum!!! It's from like 3.5 years ago!

I second the US Acoustics tho! Great quality, put out rated power! Three year warranty if bought authorized! Still go one going strong in my gf's car after 2 years!

NG

CBFryman
02-18-2005, 12:24 PM
HAHAHAHAHAH!!!!

Did you guys see what I did...this was the oldest post in the forum!!! It's from like 3.5 years ago!

I second the US Acoustics tho! Great quality, put out rated power! Three year warranty if bought authorized! Still go one going strong in my gf's car after 2 years!

NG


:werd:

threedd97
02-18-2005, 01:28 PM
I haven't been able to damage my 3 Kenwood amps. I have had them for 7 years now.

First off, why is this old ass thread rebirthed?

Second, to post some relevancy to this topic be it old as it is, I had a Kenwood amp since 2000 that I beat to death and still ran like a champ. Although I do not have it anymore due to theft, I bet it's still running in some car somewhere.

curtis73
02-18-2005, 01:38 PM
I checked the link yesterday when I posted, but today the clubknowledge site seems to be down.

Try it some other time... its a great concise list.

bumpinstang77
02-18-2005, 02:21 PM
I was about to rip u a new one FUCKIN NOOB NOAH's A NOOB AHAHAHAHAHHAHAHHHHH

ngsm13
02-18-2005, 02:32 PM
I was about to rip u a new one FUCKIN NOOB NOAH's A NOOB AHAHAHAHAHHAHAHHHHH

Noticed that I was the one who posted it twat-boy!!! Anyways, i was fuckin wasted...i did it on purpose. Clicked "last page" ont he Audio forum and replied to the last thread :)

NG

bumpinstang77
02-18-2005, 02:33 PM
that was directed to u NOOB!

Add your comment to this topic!