1978 E250 - stalls out on acceleration


tacke1la
12-14-2007, 03:42 PM
My fiance and I are somewhat stumped. Our 1978 E250 (which we just bought and are close to demanding our money back) stalls out when we add gas. When the van is in park and the brake is depressed I can step on the accelerator all I want and there is no problem. Whenever the brake is not depressed and I add gas, even just a little, it stalls out. When it's idleing it sounds like it's close to stalling out.

When we drive it the van will run ok on flat ground, but when we encounter a hill or try to speed up it stalls. The van will restart easily after it stalls, maybe having to pump the gas once every now and then.

There is a brand new battery so that's not the problem. The seller suggested we check the spark plugs and other things, but I'm trying to see if there are any other reasons that could cause such a problem.

We appreciate any help you can offer.

Thanks

Davescort97
12-15-2007, 12:34 AM
Welcome to AF. The only difference stepping on the brake could be is that the power brake booster uses vacuum from the engine to make braking easier. So, look for a vacuum leak. Check all the vacuum hoses running from the intake manifold. Make sure they are connected and in good condition. Listen for a hissing sound.

Pinch vacuum lines starting at the intake manifold. If pinching one changes the speed of the engine, that's the one that is leaking. Follow it back to find the vacuum leak. Change the fuel filter and check the air filter. Replace the PCV valve if you haven't done so. Defective ignition wires and worn spark plugs would make this problem worse.

A leaking EGR valve could be leaning the mixture out too much at idle.

Add your comment to this topic!