95 Avalon turn signals


dwhisent
12-10-2007, 10:19 PM
The turn signals and hazard flashers on my 95 Avalon quit working. I have checked fuses on the driver's side under the dash (7.5A turn signal and 10A hazard), and in the engine compartment, they test good (and have power). Parking lights illuminate. I expect the problem is the flasher, but I can't seem to locate it (nor can I locate my Haynes manual). Can anyone help me out? Thanks.

RIP
12-12-2007, 01:14 AM
Could be listed in the factory service manual waiting for you in the "Camry Service Manual" thread at the top of the forum. I would suspect it is on or near the fuse panel under the dash at bottom left.

dwhisent
12-12-2007, 09:07 AM
It doesn't seem to be located anywhere visible under the dash. I did find another reference on the internet that showed its location inside the dash behind the gauges!

Fortunately, before attempting that, I woke up and realized that although the guy that recently installed a new stereo wasn't working anywhere near the turn signals, that IS where the hazard flasher button is located. So I popped off the trim around the stereo, and sure enough, he had forgotten to plug the hazard flasher button back in. That caused both the hazard flashers and turn signals to be disabled. Plugged it back in, everything's fine.

Thanks for the reply.

RIP
12-12-2007, 08:30 PM
Good to hear it was an easy fix. Might want to at least call the stereo shop and let them know they screwed up.

zakayf86
10-09-2008, 12:01 PM
Okay, under the hood there are more fuses check those. I have replaced my dashboard and mine did the same thing and it was the fuse under the hood. I can't really describe which one it is just check it very carefully

RIP
10-10-2008, 12:08 AM
Okay, under the hood there are more fuses check those. I have replaced my dashboard and mine did the same thing and it was the fuse under the hood. I can't really describe which one it is just check it very carefully

Fixed nearly one year ago.

Add your comment to this topic!