Our Community is 705,000 Strong. Join Us.


2001 ZX2 Battery Light


DaveBurke25
11-28-2007, 08:18 AM
Question for you all...

When I get my 2001 ZX2 up to about 4K RPM (I live near the mountains - it has to be done), my battery light will flicker on and off. Once I drop back down below 4K RPM, the battery light turns off.

The car is an automatic, with about 95000 miles on it. The battery is less than a year old. This problem has been going on for about 2 months now, but the car has never failed to start. I have even ran my radio off the battery for over an hour (to see if it would die), and still the car started right up.

This confuses me, because based on my limited knowledge of cars, the battery would be used LESS when the car was going faster... someone help me!

Dave

Markb873
11-29-2007, 12:28 AM
Have the alternator bench tested at a major autoparts store, it's free, could be a bad regulator.

Davescort97
12-05-2007, 05:00 AM
Actually the battery light registers the condiltion of the generator (alternator) not the battery. It could be one of two things. At higher engine speeds the belt could be slipping on the alternator pulley. Check belt tension or automatic tensioner. The second possibility is that the brushes are worn so much that the springs can no longer hold them against the armature with enough force to conduct current at a higher engine speed. Check for glazing on the belt. A sure sign that the belt is slipping. Markb873 had good advice. Take it off and get it bench tested.

Add your comment to this topic!