Envoy flickering lights


Letteer
11-22-2007, 07:36 AM
I have an 05 XL SLT that has the dimming or flickering lights. I have had the alternator changed, and it did help for about six months, then right back at it. The dealership also tells me this is a "normal" condition. They have agreed to replace the BCP but do not think it will fix the problem. Mine does it more in cold weather, but it is like others have said, other drivers think you are flashing them because of this problem. If GM continues saying this is normal, then they will find it "normal" for us to buy other vehicles than GM. My dealership is trying, but I have been living with it for almost 2 years now, and sure don't like it. One thing they told me is to wait at least 20 seconds after starting before moving the vehicle to allow the air pump to cycle. This has helped with the flickering, but when I kick it in passing gear, at around 4000 RPM the lights just go dim and flicker. This is the only vehicle I have had that I had to wait to drive it waiting for it to finish it's stuff...very stupid. Does anyone know of any new service bulletins on this problem?

brian 1
11-22-2007, 02:46 PM
there is an update to re-flash the pcm.but it is only for short wheel base with 4.2L engine and with electric air reactor system (rpo k18).you might want to ask the dealer about this.see if this helps.post back if this works or if it does not.

truckbrandon
01-04-2008, 10:44 PM
I have a 2006 Envoy XL Denali and have the same problem, along with a slew of other annoying problems-- Bump stop, Rear Air, Rear Hatch Oil leak, Transmission bump at low speed 2wd turn, Oil sensor leak, and others. I am very disappointed in the overall quality of this vehicle. And, from what I'm reading on here, all of the problems I'm having have been reported to GM. It seems like they just don't care. Wow, no wonder Toyota is on their heals.

dhawley
01-10-2008, 09:51 PM
I found my lights were also flickering /flashing and they determined it was the instrument cluster electrical harness had shorted out. Nothing to due with battery or alternator.

envoyenvy
01-25-2008, 12:00 AM
Hey guys, I just bought a 2004 Envoy 6 months ago, and haven't had any problems up until a month ago. Flickering lights!! Likek others have said, it looks like I'm hi-beaming the car in front of me, when I'm not. All lights in my dash, radio, temp gauges, etc., flicker at the same time. I thought there may be a short as well, but it's only the lights that seem to flicker, and there is no interuption to the power to the radio, or wipers, heater, everything works as it should when the lights flicker. Don't know if tail lights flicker either, as this only happens when the vehicle is moving. Also, this seems to only occur when the sun is setting. Right around the period where there's light, but will be dark in about 20 minutes or so. If I drive the car when it's totally dark, it won't happen. Don't know what to do either???
Also, regarding lights, when I turn my ride on there seems to be no difference in the running lights brightness and when I actually turn the knob to the on position. Is this normal?

Cheers,

Add your comment to this topic!