Water pump


mj982000
10-23-2007, 08:20 AM
I just replaced the water pump on my 96 Seville, is there a certain way to put the water pump back in? Everytime I put it in (5 times so far) and get everything back together and start to put coolant in the fluid comes out the back of the water pump. Any help would be greatly appreciated.

maxwedge
10-23-2007, 03:32 PM
Welcome to AF, out the back of the pump, how?

powermaster
10-23-2007, 04:08 PM
Is this a norhtstar engine?

Cadillakin'98
10-23-2007, 05:08 PM
Sure you tightened the hose clamp tight enough?

caddydaddy
10-23-2007, 09:33 PM
There's an o-ring gasket that seals the back of the pump. Are you sure that's in there and not damaged? Also, I hope you know the pump turns COUNTER CLOCKWISE into the pump housing to tighten!

caddydaddy
10-23-2007, 09:35 PM
Is this a norhtstar engine?

Yes, it would be...only engine available for the Seville in 1996.

mj982000
10-24-2007, 07:20 AM
Yes, it's the Northstar motor. It leaks out the back of the water pump housing. Is there a certain spot where that different tab on the water pump goes?

Thanks for your reply's!!!

caddydaddy
10-24-2007, 05:26 PM
It leaks out the back of the water pump housing. Is there a certain spot where that different tab on the water pump goes?


It doesn't mention anything about that. Are you sure the O-ring gasket is installed correctly and not ripped? So it's leaking where the belt pulley is attached, correct?

mj982000
10-25-2007, 10:44 AM
I have re-installed the pump atleast 7 times. On the socket I purchased, it says that the tab should go in the 1 o'clock position of the housing. I went out last night and looked at a Haynes book and it says it should go at the 7o'clock position. I will try the 7 o'clock position when I get home tonight.

Thanks again

Add your comment to this topic!