1979 rx7 help!!!


willy_g77
09-30-2007, 12:58 PM
hello, i just bought a 1979 rx-7 with 72,386 original miles. the guy died that owned it and his wife donated it to charity and i bid and won on it. i know nothing about rotary engines other than the basic concept. im having problems find parts for it. and im having a few problems already. here goes...
the car was sitting for a couple of years with out any use. so i drained the fuel tank filled with new gas and added a can of sea foam.(carb cleaner) sparyed some starter fluid in her and she fired right up. drove her home 90 miles, and here goes the clutch feels good, but i haveto rev it a bit to take off in first, is this normal? and when i got it home i noticed gas was dripping somewhere under the carb. so i went out and started it today, and it wouldnt start without sparying starter fluid in it. so im need to know what are the first things i need to do to get this thing ready for the road. things i need to check, change, etc... thanks in advance..

jcsaleen
10-02-2007, 04:26 PM
I'm not too good with Fb's almost bought one myself though. It might be the throttle body but that's just a guess. You have the carb so it shouldn't be to hard to fix/diagnose.

www.rx7club.com (http://www.rx7club.com) will be your best friend from this moment on. If they can't help you over the net find people who are local on the forum and I'm sure they'll stop by and help.

Netsu
10-04-2007, 01:25 AM
If there was fuel coming from near the carb, check the rubber fuel lines first to make sure they are not jacked up. Fuel pressure could be too high. Also, a rebuild would be suggested. Rebuild kits are pretty inexpensive and its not hard to do. I also suggest rx7club.com, I had and FB until just recently, the police took it from me.

drftk1d
10-20-2007, 04:15 PM
it should take a little gas to start in 1st because rotaries have no torque there

Add your comment to this topic!