Page updated on 11-18-2017

99 4x4 help


burnchassis3
09-27-2007, 05:00 PM
99 vin w 4.3
when i try for auto 4wd or 4 hi it just flashes...when I stop it will go into 4 lo everytime.
I heard mention of a vacuum leak possiblle?
Can someone tell me where to check 1st?
or another possible cause?
It did this a couple times last year ,but always went into 4wd..but now it just seems to flash.
No "check engine" lights or "service 4wd" lights are on.
Thanks

MT-2500
09-27-2007, 06:38 PM
99 vin w 4.3
when i try for auto 4wd or 4 hi it just flashes...when I stop it will go into 4 lo everytime.
I heard mention of a vacuum leak possiblle?
Can someone tell me where to check 1st?
or another possible cause?
It did this a couple times last year ,but always went into 4wd..but now it just seems to flash.
No "check engine" lights or "service 4wd" lights are on.
Thanks


236 or 233 transer case?

burnchassis3
09-27-2007, 08:17 PM
Sorry MT
I am not sure how to tell?
let me know ,and I can let you know.
Thanks!
CS

MT-2500
09-28-2007, 09:42 AM
There is a tag on back of transfer case that tells what one it is or what does the shift buttons say?
if they have a 4W auto on one shift button it will be a 236.
A 236 can be tested and checked for codes with a transmission/engine capaable scanner.
A 233 you can pull codes by grounding pin 13 on diagnostic connector.

In how to section there is some info on the 233 transfer case.
http://www.automotiveforums.com/vbulletin/showthread.php?t=572914

burnchassis3
09-28-2007, 04:52 PM
I have 4wd auto switch ,so it must be a 236.
now for the vacuum........I bet I have a leak,can you tell me which hose is a vacuum hose for the 4wd? or where I can locate this to start looking.
Thanks!
CS

MT-2500
09-28-2007, 05:30 PM
I have 4wd auto switch ,so it must be a 236.
now for the vacuum........I bet I have a leak,can you tell me which hose is a vacuum hose for the 4wd? or where I can locate this to start looking.
Thanks!
CS
Sorry I can not find a vacuum diagram for it.
You might check a factory repair manual.
If the shift button lights are flashing I would check for codes first.
On vacuum.
I would start at front actuator switch and see if it is getting good vacuum to it and threw it.
Is you front axel locking in?
Can you hear transfer case shift or is it going into 4W low ok?
MT

burnchassis3
09-28-2007, 07:59 PM
Yes it drops right into 4wd low.clunking and all.....its in 4wd low too I hammered it ,and about ripped the wheels off.
CS

MT-2500
09-28-2007, 08:06 PM
If it goes into 4 W low the vacuum is working.
Get it on a transmission/transfer case scanner and run the scanner test and post back codes.

Add your comment to this topic!