Page updated on 11-17-2017

GMC Jimmy Hot/Cold Again with New Gear?? Help please.


RocketAF
09-27-2007, 12:53 AM
Hi,
I had the problem with the Blend Motor switching from Hot to Cold with the clicking sound. Finally it stopped clicking and just blew Hot Air while on AC. I removed the Blend Motor and Replaced the cracked Gear. Now while in the AC mode, its blowing Hot and then Cold, just like before. Is there something that controls the Blend Motor that could be bad? A friend said that I may need to have the Blend Motor Reprogramed since I replaced the gear and it might not be in the correct place and that only a Dealer can reprogram it. Since this has been driving me nuts all summer, without AC, any help would be Greatly Appreciated!!!

Thanks .....Rocket

MT-2500
09-27-2007, 09:40 AM
Welcome to AF.

Try pulling the fuse and put it back in and see is it will reset itself.
MT

RocketAF
09-27-2007, 03:18 PM
Welcome to AF.

Try pulling the fuse and put it back in and see is it will reset itself.
MT

Thanks! I'll try it tonight when I get home. ...Rocket

old_master
09-27-2007, 07:03 PM
What year, make, model and does it have manual or auto climate control?

RocketAF
09-27-2007, 09:44 PM
What year, make, model and does it have manual or auto climate control?

Its a 1998 GMC Jimmy 4dr regular with Auto Climate Control. Before I installed a new gear on the Blend Motor, it would only put out Hot air, after install, it now switches back and forth from Hott to Cold. I've tried pulling the Fuse and waiting about 5mins to see if that would reset it. It appears the Climate Contol isn't in sync with the Blend Motor. Any thoughts? Please?

Thanks ...Ron

Add your comment to this topic!