Our Community is 705,000 Strong. Join Us.


Fried my car battery while giving boost


qwerll
09-19-2007, 06:10 PM
ok, i drive a 93 honda civic ex, my car died so i had to give it a boost. I accidently hooked up the negative pole with the positive and tried to give it a boost, nothing happened so i realized i had made the mistake. The day after i took the battery to a shop and got it charged up, i brought it home and tried to boost up my car again, and again nothing happened. Could someone please help me thankyou.

steviek
09-19-2007, 06:25 PM
does anything work? like interior lights etc?
most likely a fuse or relay, they put them in the car for things exactly like this

qwerll
09-19-2007, 06:30 PM
nothing works, the cars completely dead

SilvrEclipse
09-19-2007, 06:41 PM
Check all of your fuses in your car. You might have messed up the battery.

qwerll
09-19-2007, 06:43 PM
alright. thanks mayn

gthompson97
09-19-2007, 07:24 PM
Battery is toast. You'll be lucky if that was all you did too. Being a 93, it probably doesn't have any type of protection against that, so you might have fried a shitload of fuses/relays and possibly the ECU/TCU.

qwerll
09-19-2007, 08:08 PM
what do you think the chances are of it having fried my ecu

gthompson97
09-19-2007, 08:21 PM
How long was it hooked up backwards? The longer the worse it is for the car.

Thor06
09-19-2007, 10:15 PM
I just touched the wrong ones twice and nothing bad happened to either of the Talons I was jumping (my purple one and the black parts car before it became a parts car) or the donor car (my Cavy). On 1g DSMs there is a fuse that keeps the overall output below 80A and my guess is you just popped that. I would be hardpressed to believe that. Was the battery in the car when you did this in like a jump situation or was it on a charger?

caniborrow50cnts
09-20-2007, 01:29 PM
battery on your car likely toasted, alternator fuse might be gone.
Considering this is like the 10th post in this thread...
Why don't you check out the civic page and see if they have additional info. While the issue is general, the fix is quite different.
I only have experience with that car because my brother owned two of them, and doesnt know how to fix things. If you jumped it backwards, the battery will almost always be fried. It will usually come up as a dead cell or short cell at first, then nothing. If absolutly nothing comes on, its the battery. The computer has nothing to do with the interior lights, dash, or starter. The starter will still turn provided it had power from the battery. The computer is not likely to be shot since thats what fuses are for. See if you can disconnect the battery, then using jumper cables, connect it to a fully charged battery somewhere. if the car starts and stays running after the cable is disconnected, the alternator is still good. if it dies immediately upon disconnection, the alternator fuse or alternator itself is gone. if nothing happens when you connect a different fully charged battery, you might have melted some very important wires.

Add your comment to this topic!