Page updated on 11-19-2017

Lifter Problems


dawnr217
09-19-2007, 12:34 PM
We have a 99 Bravada and when you start it up the engine clicks. Was told it was a lifter that is stuck and to just put some Marvelous Mystery Oil in and it will be fine. That did not work and I would like to know what I need to do to get this fixed. Any suggestions would help greatly. We gave the car to my daughter and would like to see it last at least another year. Help Please.

taillight
09-19-2007, 12:45 PM
Put an oil pressure guage on the engine and see what the oil pressure is.

Chris Stewart
09-19-2007, 07:10 PM
My '97 did the same thing when the mornings got cold, the colder old oil must've thickened up. An oil (10W-30 in Tenn., further north may need 5W-30) and filter change was always due about that time too and quieted that lifter right down.

dawnr217
09-20-2007, 07:21 AM
Oil pressure is fine. We had the oil and filter changed about 2500 miles ago. We have it done every 5000 miles. What else can I do? Should I go ahead and have the oil and filter changed now and use a different oil?

taillight
09-20-2007, 08:13 AM
Like Chris said if you are not using 5W30 try it.

scheds41
10-04-2007, 06:13 PM
I have a 00 with the same prpoblem, but it sounds more like a knock than a lifter tick. It goes away within the first 2 - 3 minutes of driving. And it only happens when the weather gets cooler. I was told it's a fairly common problem on the Bravada, and that as long as the sound goes away, not to worry about it much. Just keep changing the oil regularly and use the lowest weight oil recommended for that vehicle.

blazee
10-04-2007, 06:18 PM
Are you guys using Fram oil filters?

Chris Stewart
10-04-2007, 07:10 PM
Never!
AC Delco in the gassers and Purolater Micronic in the Cummins.

scheds41
10-05-2007, 03:03 PM
Yes, I use Fram 95% of the time.

old_master
10-05-2007, 10:27 PM
Yes, I use Fram 95% of the time.

Stop using Fram and you'll have 95% fewer problems!

matt_o_70
10-06-2007, 08:25 PM
before you get too worried I'd change the oil. I have a 2000 that when the oil starts to break down the lifters start to click at startup, changing the oil always makes her silent again.

This seems to be an issue with hydraulic lifters. I am not a big fan of hydraulic lifters!

scheds41
10-08-2007, 11:54 AM
I had heard that before, but not sure where. It's about time for an oil change, so I'll take your advice. I know I have a lot of milesa dn that has something to do with it too. 193k Runs great except for the tick/knock at startup sometimes.

Thanks to all,

Add your comment to this topic!