Page updated on 09-26-2017

'97 Blazer o2 sensor?


cma830
09-11-2007, 03:47 PM
Hi...Can someone please tell me how many o2 sensors a 97 s-10 blazer 4WD has? My "service engine soon" light is on and I went to a repair shop to find out why, they told me it was the o2 sensor on the passenger side...Well I had that changed and the light never went off. It is still on and it's been about a week..Well, it did go off for a very short time after we disconnected the battery thinking we had to reset the computer, but it came right back on...Maybe the o2 sensor is defective? or did we change the wrong one?? Any help would be greatly appreciated.
Thanks in advance

blazes9395
09-11-2007, 05:40 PM
At least three. I don't remember if the '97's now had four or not.
One on driver side, one on pasenger side and one after the cat convertor. If you have four(I doubt it), the passenger side would have two in a sense, one up closer to the engine, and one before the cat convertor.

cma830
09-12-2007, 04:30 AM
Thanks...I bet the wrong one was changed. Or, does the "engine light" usually go off right away or can it take a while?

MT-2500
09-12-2007, 08:38 AM
Thanks...I bet the wrong one was changed. Or, does the "engine light" usually go off right away or can it take a while?


First a code does not say replace the sensor.
It says check it out.
Many things can set a code.
The code has to be cleared with a scanner to reset the VCM.

What engine and what was the code no?

cma830
09-14-2007, 04:32 AM
Don't know what code no. it was, but I will be going back to the repair shop to get this figured out...Thanks for the help. :licka:

Add your comment to this topic!