Page updated on 09-26-2017

4.3 Knocking


justins_s10
08-27-2007, 07:21 AM
I have a 91 S10 4.3 TBI Z with the 700r4 tranny. My question is that my engine knocks at idle but stops doing it as soon as you give it gas. The knocking is worse when the engine is cold but when warmed up it quiets down, but runs very rough when warmed up. Like it will surge forward at lights and give off such a bad gas smell that people around me have to roll up their windows. When I press the gas i can see the black smoke coming out of the tailpipe out of my mirror, and if i am making turns and press the gas it will lose power for a second and then the power will come back. I just changed the plugs wires and rotor but it runs just as bad as the old crap did. Whats sad is that this truck only has 90,000 miles and i knew the owner before it and he took very good care of it with oil changes every 3000 miles. I hope you all can figure this one out as this is my only vehicle i have and can't have it blow up on me as my other s10 did, but that one had over 300,000 miles on it so I expected that one to go anyway.

taillight
08-27-2007, 09:01 AM
Pull your trouble codes and fix any that you have. Start there.

justins_s10
08-27-2007, 09:35 AM
I will check the codes, but the check engine light comes on maybe once a week. I tryed adding lucas oil stablizer to see if it would help the engine, and all that did was make it knock louder, so i ended up having to drain all the oil out and put in thinner oil. This engine does not like thick oil at all, all it will do is rattle, ping, and miss. But why only at idle. It doesn't blow blue or black smoke and nothing leaks, all this engine does is blow clouds of black smoke that smells like sulfur out when you start it up in the morning or gun it to pass someone.

blazes9395
08-27-2007, 10:21 AM
Lucas stabilizer is junk in my opinion. I use to use it but, when I found out some more info on it, I would not reccomend using it. As for you rich running condition, if you have any codes coming up, post them on here and go from there.

scholzee
08-27-2007, 11:21 AM
Black smoke and people rolling up windows is alot of gas in thr notor. The extra gas could dilute the oil and take out a rod bearing. Sounds like you may have a rod bearing in the early stages of failing. They will knock at lower rpm and quiet up at highr rpm. I would recommend not driving it much and get it to a competant mechanic, you can sometimes change the rod bearings from underneath with the motor in the truck.

justins_s10
08-27-2007, 11:52 PM
The mechanic said the motor isn't worth rebuilding but will run for another 50,000 if i am easy on it. The previous owner of this truck had the top end rebuilt at 60,000(blown head gasket). Funny because I thought that 4.3s were good engines. The old owner always changed the fluids, kept it tuned up, and never used it for towing, but it never ran correctly, so he just bought another truck.
Another question, whenever i turn left or right and then press the gas it will lose power for a few seconds and sound like a old beater truck then run normal after you straighten the wheel out. What does this sound like to you about loosing power while turning.

justins_s10
08-30-2007, 09:34 AM
Any Ideas? I tryed everything to fix the power loss while turning. I was thinking the fuel pump, but then why would it be running rich. Could it be my injectors.

Add your comment to this topic!