Engine will only idle for 5-8 seconds..Help me!


jimmycrackorn
08-27-2007, 04:41 AM
first off, 96 subaru legacy automatic...the problem; when the engine starts, it will idle for 5-8 seconds then it stalls...i cant get it out of the driveway..ive started looking for the problem in the normal places...fuel filter is fine, fuel pump is working,i changed and gapped the plugs, they are all fine...where do i go from here..? i know shes getting fuel but i think it might be a sensor or I.A.C. .im sure it could be anything..i am by no means an expert...so any help would be greatly appreciated....thanks

StNicholas
10-02-2007, 09:49 AM
There is an onboard computer with a self-diagnostic system. Generally referred to as an OBD-II system. Scanners to check the codes are available at most auto parts stores. Some will check these for free (AutoZone I believe is one). Or, you can purchase such a system (ca. $100). Borrow or rent? Maybe.

Check out www.obdii.com for more info on OBD-II.

Nick

Demon_Crest
10-04-2007, 12:34 AM
It might also help to see if there are any loose, or worn out vaccum lines

maurerush2112
10-10-2007, 08:45 AM
have 99 legacy l with exact prob.
diagnostics do not show any prob.
went through 3 fuel pumps thinking that was prob. i made mistake of putting reman. in first time, then getting new reman under warranty for number 2. bought new dephi pump for number3. so far o.k.
did i fix? don't know. wife said it did it again recently. started up for 5-6 sec. then dies.
from my experience i believe its either cam sensor, or pcm. the latter will cost dearly to replace/program

Add your comment to this topic!