Staling at idle


DigitalBones
08-25-2007, 08:02 AM
On my 900 se,I recently had a new fuel pump installed. After a week or so, I pulled up to a red light and the car (http://www.saabnet.com/tsn/bb/NG900/index.html?bID=217179#) idled down to near zero rpms, and stalled.

This continued for the rest of the day, anytime the car was stationary. Later in the evening, the problem went away, but the car idled at 1500rpm and ran roughly.
I disconnected and reconnected the battery
, and the car ran better with some jumps in RPM when idle, but nothing significant.

After 150 miles or so, and the car was back to stalling at idle. And again, after a day or so this problem went away and the car idles at 1500 rpm.
What could be the underlying issue here?

I'm going to install a new fuel filter today. Maybe the new "stronger" fuel pump picked up some sediment from the tank and clogged the filter?

Any help would be greatly appreciated!

hakachukai
11-15-2007, 04:04 AM
Yeah, my first guess would be to check the fuel system. If you have a fuel pressure gaudge check the fuel pressure while it is idling. See if the pressure drops when it starts acting up.

If it doesn't, then you could possibly be looking at a clogged injector.

If you fuel system check out ok, check the Idle Air Control valve (IAC). That is a common mishap for FI cars not idleing. Make sure that it's opening.

I've also heard that a faulty Throttle Position Sensor (TPS) can cause problem while idling.

you can check the spark plugs too. See if you get any clues from the color or condition of the plugs.

Hope that helps

Add your comment to this topic!