92 Prizm Brake Problems!!!


qwerty1986
07-04-2007, 01:30 AM
Ok, i am stumped at this point, 3 days ago my brake pedal went to the floor and lost about 75% of my stopping ability. i have replaced the front pads, both rotors, both calipers, and today a brand new master cylinder in it. i have completly bled the system with all new fluid and yet my pedal still goes to the floor. does anyone here know what it could be? i just spent over $300 in new parts and still no luck. it doesn't leak fluid anywhere, i am stumped and getting upset :banghead: with this POS car lol! please help:runaround: .. thank you

n0rt0n
08-21-2007, 11:43 AM
Yeah its your rear Shoes and Drums. Replace them. There was probably nothing wrong with the fronts or the master.

Ok, i am stumped at this point, 3 days ago my brake pedal went to the floor and lost about 75% of my stopping ability. i have replaced the front pads, both rotors, both calipers, and today a brand new master cylinder in it. i have completly bled the system with all new fluid and yet my pedal still goes to the floor. does anyone here know what it could be? i just spent over $300 in new parts and still no luck. it doesn't leak fluid anywhere, i am stumped and getting upset :banghead: with this POS car lol! please help:runaround: .. thank you

jhanley
10-17-2007, 08:14 PM
Did the rear shoes fix it??? I just picked up a 96 prizm with the same proble and i replaced the master cylinder and it didnt fix it?? Thanks

qwerty1986
11-28-2007, 07:23 PM
i replaced both wheel cylinders shoes and miked the drums, they were fine. then i replaced all the lines with new and still same problem.. after close to a grand later i find the problem.. it was a clip for the front pads that was missing!!!! a $10 kit and now it works great :banghead: :runaround:

johnholl
12-19-2007, 03:17 PM
i replaced both wheel cylinders shoes and miked the drums, they were fine. then i replaced all the lines with new and still same problem.. after close to a grand later i find the problem.. it was a clip for the front pads that was missing!!!! a $10 kit and now it works great :banghead: :runaround:


What clip. Is it an alighment clip which goes between the inboard and outboard pad?

qwerty1986
12-29-2007, 02:42 PM
it was the pad clip that goes btwn the pad and the caliper. allows the pad to slide.. without it the pad was not moving with the caliper it was sitting in 1 place on the rotor..

Add your comment to this topic!