renault clio 11 overheating, fan not spinning, please help


ugy101
06-28-2007, 01:56 PM
hi,

i have a renault clio11 1.2 1999(v), the car has started to overheat, i think it is because the radiator fan does not spin to cool it down.

i took the switch off connecting to the coolant temperature sensor(CTS) and the fan starts spinning when the car is started, so i thought it would be the CTS, i have replaced this but the fan still does not spin, what could be the problem, do you think the thermostat could be causing the problem? the only thing about that is that when the fan spins(remember when i disconnect the switch from the CTS) the engine runs fine at half way temperature, so if the thermostat was not opening to let the coolant throught, wouldn't the car still overheat??

please can anyone help, i have already payed about 22 for a sensor i did not need :shakehead

greg2645
07-15-2007, 08:12 AM
I am having exactly the same problem.... when you say you replaced the CTS do you mean the screw in sensor with the 3 pin plug? I have done some testing of the wires and that seems to be the only bit that i cant get the proper numbers back from.... If you got yours fixed i would really like to know how!

Thanks

ugy101
07-15-2007, 08:29 PM
I am having exactly the same problem.... when you say you replaced the CTS do you mean the screw in sensor with the 3 pin plug? I have done some testing of the wires and that seems to be the only bit that i cant get the proper numbers back from.... If you got yours fixed i would really like to know how!

Thanks

hi,

yes the cts is the three pin screw in socket that goes in the head near the thermostat, i have no idea as to how to fix it, although i did a bit of testing on my car, when i turn my dim lights on the tmep guage in the car moves up a notch, then another notch when the full beams are turned on, i i turn my heater on then usually the temp of the car should go down, but this propmts the temp gauge to climb another notch, i believe it has to be a wiring fault somewhere but i don't really know, can you explain a bit more on your testings and findings please, or if there is anyone who has had this problem and resolved it please reply, does anyone know how much the renault dealers charge to check for faults?

thanks in advance

Add your comment to this topic!