Page updated on 12-12-2017

91 s-15 speedometer quit working


tomfree99
06-15-2007, 06:58 PM
Just replaced computer in my 91 S-15 sonoma w/2.5 4 cyl. Problem is that now the speedometer has quit working. Replaced sensor on rear of tranny, no change. Could speed sensor on dash have been fried? Or maybe something else. Oh. The shift now light has also stopped showing up. Sure they are connected but where?

MT-2500
06-16-2007, 10:24 AM
Just replaced computer in my 91 S-15 sonoma w/2.5 4 cyl. Problem is that now the speedometer has quit working. Replaced sensor on rear of tranny, no change. Could speed sensor on dash have been fried? Or maybe something else. Oh. The shift now light has also stopped showing up. Sure they are connected but where?

You need to get it on a scanner and see if the pcm is getting a speed sensor signal.

Did it quit at the time pcm was replaced?
Did you use you old prom out of your old pcm?
Why did you replace pcm?
Also check all fuses.

tomfree99
06-16-2007, 02:51 PM
Original symptom this time was severe overfueling. Mechanic diagnosed as computer problem, not to mention that engine has idled very rough for quite some time and computer would not go into diagnostic mode. The computer was replaced with a used one and I'm sure he did not use my old prom. Think i should put my original prom into this comp ?

MT-2500
06-16-2007, 02:59 PM
Yes you need to keep your old prom with the truck.
Did the speedometer quit at the same time the pcm was switched?

tomfree99
06-16-2007, 05:34 PM
Man, what an idiot that mechanic was. He did not plug up a little module bolted on side of computer. All is well in smallville now that i disconnected power and reconnected the module. Evidently it is a necessary part of making speedometer work. Thanks for replying.

MT-2500
06-16-2007, 06:56 PM
That will do things like that.
You are welcome and thanks for posting back the fix.
Glad all is well and working.
MT

Add your comment to this topic!