Page updated on 12-11-2017

1999 Blazer misses & shakes


srs469
06-07-2007, 02:43 PM
truck has 217000km I have a miss/shake in the 1500-3500rpm range regardless of speed. The truck runs great around 120 k/hr but shakes like a bitch at 90k/hr. I've changed rotor, plugs,wires, distibutor cap, fuel filtre and checked fuel pressure and it looks good. Any suggestions

MT-2500
06-07-2007, 04:33 PM
What engine?
What brand of plugs?
What does the codes say about it?
Post back code no.
Any miss fire cylinders?
MT

srs469
06-07-2007, 05:12 PM
4.3 engine
ac delco plugs
no codes
no detected cylinder it idles great revs good in driveway but under even slight load it has a miss

MT-2500
06-07-2007, 05:36 PM
What is the fuel pressure reading?
Is the coil putting out good hot blue spark to all plugs?
May be time for a good engine capable scanner.
If it is missing a good engine capable sscanner should be showing some miss fire codes past or present or history?

What is the camshaft retard setting reading.

srs469
06-08-2007, 07:16 AM
I did the fuel pressure last week not sure on the numbers now but the where whithin the range i've seen on the site
i just have an obd11 scanner so i don't know the retard setting on camshaft
not sure on the hot blue spark but when i check with a test light I'm getting spark at each plug

A couple of questions

the resitance on the coil is 7000 ohms range is 5000-25000 from what i've read. is this low reading a sign itr's on the way out?

a mechanic friend suggested it could be the lock up torque converter is there a way to disable this to check?

MT-2500
06-08-2007, 10:15 AM
The coil ohm test just shows if the coil is dead at the time you check it.
To check for good coil look for good hot blue spark when hot.
If it puts out good hot blue spark that will jump 1/4-1/2 in. hot it is good.

On TCC tap the brake pedal just enough to turn on brake lights to turn it off.

srs469
06-11-2007, 12:46 PM
the shake got worse so i started looking at drive train, turns out front u joint was starting to go. never had a bad u joint feel like that before.
the miss seems to have gone away after a egr valve cleaning wich wasn't very dirty & a map sensor cleaning

blazes9395
06-11-2007, 02:21 PM
I was going to say EGR, but you beat me to it! These valves seem to get dirty and stick open and you get all sorts of problems, and the kicker is the PCM will not always throw a code for it. The better engine scanners would most likely find the problem, but the cheaper scanners will not.

Add your comment to this topic!