2002 Taurus odd dash light problem - intermittent


bfarnsle
06-05-2007, 09:53 PM
Hi all,
2002 Ford Taurus with the flex fuel engine. Almost 100K miles.

Very odd thing has happened. Sometimes when we turn on the headlights .. the inside background lights (the lights that light up the radio, behind the speedometer, etc) .. some of them work, and some of them wont.

You basically cant see how fast your going when it is dark because you cant see the speedometer. Both turn signal lights on the dash are stuck "on". The lights all around the dash (trunk, engine light, etc... ) all work as normal.

The odd thing is, we can drive down the road for 10 minutes and presto chango everything starts working... and then 10 minutes later everything switches back again..

75% of the time, you just drive without being able to see the speedometer.

Anybody have any ideas? No codes show up on Autozone's handheld computer.

Thanks for the help!
Brian

shorod
06-05-2007, 11:34 PM
The turn signal indicators staying illuminated sounds suspicious of a grounding problem. This could be either in the instrument cluster, or more likely at one of the bulb sockets. Do they get brighter when the turn signals are switched on?

The rest of the lighting issues sound like a connection concern. There have been other's who have posted about issues with the mylar flex cable assembly for the instrument cluster. I don't recall seeing other with a 2002 model year having issues, I thought it was more mid-1990's, but don't hold me to that.

I had an issue on my 1998 Taurus where the button backlighting for the radio would intermittantly work. I ended up taking the head unit apart, tracing the backlighting circuit, and re-soldering all the joints and filling the vias with solder. When I got it back together, the illumination worked reliably and continued to work for the couple of years until I sold the car. As far as I know, they are still working. Maybe you have a similar issue.

-Rod

bfarnsle
06-07-2007, 09:37 PM
The lights do not get any brighter when the turn signals are on.
Thanks!!

I found this on another thread: IF ANYONE HAS SUGGESTIONS ON HOW TO GET THE DIMMER SWITCH OUT, PLEASE LET ME KNOW!!

Lights are not working behind instrument panel. I have checked the fuses I believe they are good, there is not one specific fuse for panel. Lights must be burned out behind panel. How do you remove the instrument panel to get behind the speedometer?

Micaron 08-14-2005, 01:55 AM It's very rare that all the lights would go out at the same time. Does the Stereo and Heat - A/C controls light up? If not, I would say this could be a problem with the "Dimmer Switch" which is loacted right beside the control for your Headlamps...

Move it back and forth. Sometimes the switch gets a short in it. Easy to install if you have to replace...

Bigdawg66 08-14-2005, 07:32 AM The radio, ac & heater control lights work just fine with the dimmer. That is what is confusing me. I'm not sure how I would check power to the dash lights?

97chevylumina 12-28-2005, 10:41 PM The radio, ac & heater control lights work just fine with the dimmer. That is what is confusing me. I'm not sure how I would check power to the dash lights?

I have a 2002 taurus SEL 3.0L 24v duratec with 125,000 kms
and having a similar problem. Instrument cluster lights not working,
but radio and heater panel lights OK.
Turn signal indicator lights are continuously on, and can be dimmed
by the dimmer switch..
What was you problem, and what did you do to resolve it.

Thanks

97chevylumina 12-28-2005, 10:41 PM The radio, ac & heater control lights work just fine with the dimmer. That is what is confusing me. I'm not sure how I would check power to the dash lights?

I have a 2002 taurus SEL 3.0L 24v duratec with 125,000 kms
and having a similar problem. Instrument cluster lights not working,
but radio and heater panel lights OK.
Turn signal indicator lights are continuously on, and can be dimmed
by the dimmer switch..
What was you problem, and what did you do to resolve it.

Thanks

Bigdawg66 12-29-2005, 06:22 PM I have a 2002 taurus SEL 3.0L 24v duratec with 125,000 kms
and having a similar problem. Instrument cluster lights not working,
but radio and heater panel lights OK.
Turn signal indicator lights are continuously on, and can be dimmed
by the dimmer switch..
What was you problem, and what did you do to resolve it.

Thanks
I pulled apart the whole dash and checked everything associated with the problem. It ended up being the dimmer switch. Thanks for checking, good luck. Happy New Year!!

02taurus_sel
07-28-2007, 09:38 PM
I have a 02 Taurus SEL and started having the same problem instrument cluster bulbs not light, L/R signal indicators continuously on until I selected the left/right turn indicator, then they would flash normally, and yet all the
other dash lights worked ( radio, heater, etc) OK. The problem was intermittant.I posted/read reviews and tolerated it for quite some time. I finally removed the instrument cluster, replaced ALL 5 bulbs, replaced the cluster and have not had any problems since. I had to buy the Radio Removal tool through Snap-On, about $13.00
A couple hours work, but well worth it.
Good Luck

dsd3519
01-08-2011, 10:51 PM
I have the same problem with my 2002 Taurus. Turn on headlights and all the dash lights (except the blinker indicators staying on solid) go out.
So, should I start with the dimmer switch, or the cluster?

shorod
01-09-2011, 12:57 PM
Welcome to the forum, and THANK YOU for searching for answers before starting a new thread!

Where I'd suggest you start, if you haven't already, is by making sure the dimmer is adjusted up. Obviously if the dimmer is turned all the way down, you will have no or very little instrument illumination. The dimmer feature in your 2002 is a Pulse Width Modulated (PWM) solid state dimmer. If you have an oscilloscope you could clearly tell if the dimmer output is functioning properly, but even a DMM on the DC setting should give you a good idea if it's functioning.

-Rod

dsd3519
01-11-2011, 08:48 PM
Thanks for the reply. I'll check it out.

ShannonDawn
08-30-2013, 08:30 PM
Have read the posts concerning this issue. I have a 2002 Ford Taurus and have had this issue since I bought the car a year ago. I do notice that when it is warmer out, or when I would crank the heater this past winter the lights would start working again. This leads me to believe that something is being "dried out" enough for contact to be made. Meaning there is condensation or something in either the bulb sockets or maybe in the connections to the panel wiring. My question is, where do I find the "how to" section on disassembling the dash to get to the bulbs and wiring? I apologize for the simplicity of my post. I am not a mechanic nor do I pretend to be one, but I DO roll up my sleeves and get my hands dirty before I pay to have a mechanic tell me they cant figure it out. :thinkerg:

Add your comment to this topic!