LCD Gone?


DrScud
10-22-2002, 02:45 PM
1996 LS 400 - Sound System backlight gone. Dealer says $1700 parts, $150 labor. Unacceptable. What are my alternatives? Has anyone else had this problem?

DrScud
10-27-2002, 10:46 AM
I can't believe that I am the only person with a LS400 that has had this problem. No lighting on the sound system display is a pain at night. Certainly someone has had this happen to their car. Can anyone give me a clue as to what the options are to get this fixed??
Thanks

hanuman007
11-01-2002, 10:00 PM
if you can still see the led, however the back light green is not on. you can take the unit apart and change the bulbs.

my problem is the the opposite. my HVAC control lights up however the led is black.

DrScud
11-02-2002, 12:02 PM
Yes the LCD is readable but the green lights are gone. Are there light bulbs for the green lights that can be changed inside??? Are there any instructions available to take out the radio to change the bulbs?

DrScud
11-02-2002, 12:05 PM
There is a company called Mikado in South San Francisco that will rebuild LCD displays. You can send them the LCD assembly and they will fix it for you. If you take it in to them they will do it for $295.00 and it can be done in an afternoon.

hanuman007
11-04-2002, 07:30 AM
there are no instructions per say. You have to take the unit out and look on top and bottom of the unit for little bulb sockets. you can unscrew them and take the bulb out then put the new bulb back in. its pretty easy. i have done this for my suspension, power, and sport mode switches. you may even have to take the the covers off, the bulbs may be located on the inside.

i hope it helps

nahmed
01-16-2003, 03:25 PM
If it's just your radio that needs fixin, call up United Radio in Syracuse, NY Providing your radio is the Pioneer. They should be able to fix it somewhere in the 2humdred range. ANything else, call Mikado. THat's what I did for mine

Earl!
01-24-2004, 05:37 PM
Ahhh my first post here :biggrin:.

I think you guys need to check out my website, The Lexls.com: http://www.lexls.com

I've got picture tutorials for many things, one of those being a DIY LCD fix.
http://www.lexls.com/climateLCDscreen.html If you already have it fixed you can see how its done.

That tutorial also includes info on how to replace backlighting bulbs, including the Lexus part numbers. It is for the CCU specifically, but the stereo is built in a similar fashion. It sounds like your bulbs are burned out DrScud. If you don't wanna repair the stereo yourself check out this site: http://carstereohelp.com/lexus.htm They offer fixes for different type of Lex stereo problems.

Edit: Didn't see this was such an old thread, you probably have it fixed already!

manchurvideo
04-24-2004, 08:11 PM
Now my first posting here ! !

I want to thank EARL! (above) very much for his kindness in showing all on this forum HOW-TO slove/correct the problem many of us face.
KUDOS to you my friend !!

Classic400
05-29-2004, 08:20 AM
Ahhh my first post here :biggrin:.

I think you guys need to check out my website, The LS Resource: http://www.pearsonimaging.com/LS

I've got picture tutorials for many things, one of those being a DIY LCD fix.
http://www.pearsonimaging.com/LS/climateLCDscreen.html If you already have it fixed you can see how its done.

That tutorial also includes info on how to replace backlighting bulbs, including the Lexus part numbers. It is for the CCU specifically, but the stereo is built in a similar fashion. It sounds like your bulbs are burned out DrScud. If you don't wanna repair the stereo yourself check out this site: http://carstereohelp.com/lexus.htm They offer fixes for different type of Lex stereo problems.

Edit: Didn't see this was such an old thread, you probably have it fixed already!

i've used your most helpful site before, so i'm grateful for this opportunity to thank you on behalf of myself and all the other Lexus owners who've found your information invaluable. thanks again!

gvm
03-23-2006, 11:38 PM
This thread is very useful, thank you. My problem is with the sound system and it is that both the LCD backlight and the backlight for the switches have gone dead simultaneously. Does this sound like a simple dead bulb problem please?
TIA ... Greg

gvm
03-24-2006, 12:10 AM
More information about my problem of backlight for both LCD and switches going dead. My LS400 is a 1996 model and the sound system is the premium sound system so I figure the brand is Nakamichi. Can anyone confirm what is involved in fixing this problem please?

PS. www.lexls.com (http://www.lexls.com) is positively excellent but I wonder if there's a similar site for 2nd generation LS400s?

TIA ... Greg

Add your comment to this topic!