2003 cinco hard start when cold


facial1
05-07-2007, 10:29 AM
We have a 2003 Kio Cinco that will start but cough an sputter and die several times when the car is cold. Once it starts and stay started it runs fine the rest of the day. Could this be an automatic choke problem or maybe something more sinister????

Thanks for any advice:frown:

Fastshivy
05-07-2007, 02:23 PM
Could be an engine coolant temperature sensor. They are usually in the cyl head somewhere. When cold it tells the computer to send more fuel to the injectors. As the engine warms up it leans the mixture out. Not sure where it is on your specfic car, but you can go to a parts site to identify it..like importedcarparts.com or any site of your preference.

:lol:

facial1
05-09-2007, 11:17 PM
My daughter, who drives this car, says if she pumps the gas pedal a few times the car will start right up. Since it's fuel injected I don't understand why pumping the gas pedal would matter. Am I missing something????

Thanks

Fastshivy
05-10-2007, 08:34 AM
She might be altering the voltage on the tps (throttle position sensor)...worth checking out. Honestly I am not sure these cars use them, but many do. Another thought might be she is letting more air in and clearing a flooded condition...like a stuck injector or bad fuel pressure regulator.

What happens when she holds it to the floor and tries to start it?

facial1
05-11-2007, 08:41 AM
I went out this AM and push the gas pedal down then tried to start the car...it just coughed and sputtered then died. I wonder if having the fuel injectors cleaned might help?? What's odd is that it will cough and sputter several times then all of a sudden start and run like a top...It's still under warrenty but the closest dealer is 2.5 hours away. I'd like to explore all my options before I make the trip to the dealer.

thanks for any help

Add your comment to this topic!