Page updated on 12-10-2017

Abs Sign On A 95 Infiniti G20. Help!


ravisher78
04-14-2007, 08:03 AM
ok so i bought a 95 infiniti g20 with around 42k miles on it. it now has around 55k miles. ever since i have bought the car it has proven to be the most unreliable and costly to me. i thought the name INFINITI should be enough... cuz i know they are pretty high end cars ...but apprantely not so.
there have constantly been problems with this car and i dont know whats going on now.
THE ABS LIGHT comes on and off in it. some times it comes on and then sometimes it doesent. after i start the car the light comes on in about 2-5 minutes. and then when i take the key out and restart the sign may or may not come on. another problem i have with the brakes is that i hear some sort of a noise from the drivers side wheel when i try to brake. its sounds like a lion....GRRRRRRRR. i had to change the master cylindr during the inspection procedure cuz it had some oil around it... i dont know if this is whats caused it but im not so sure. i did get all the four brake pads changed during inspection too...so they are new also. but it still beats me why this light comes on....any ideas fellas??
would appreciate any help.

ravisher78
05-10-2007, 09:03 AM
ok so i bought a 95 infiniti g20 with around 42k miles on it. it now has around 55k miles. ever since i have bought the car it has proven to be the most unreliable and costly to me. i thought the name INFINITI should be enough... cuz i know they are pretty high end cars ...but apprantely not so.
there have constantly been problems with this car and i dont know whats going on now.
THE ABS LIGHT comes on and off in it. some times it comes on and then sometimes it doesent. after i start the car the light comes on in about 2-5 minutes. and then when i take the key out and restart the sign may or may not come on. another problem i have with the brakes is that i hear some sort of a noise from the drivers side wheel when i try to brake. its sounds like a lion....GRRRRRRRR. i had to change the master cylindr during the inspection procedure cuz it had some oil around it... i dont know if this is whats caused it but im not so sure. i did get all the four brake pads changed during inspection too...so they are new also. but it still beats me why this light comes on....any ideas fellas??
would appreciate any help.


ok fellas.... so u dont want to help me :( .... but this is what i did with the problem im having with the g20... i went to the junk yard and pulled out a couple of ABS wheel sensors for front wheels.... came back took out the old ones and put the NEW OLD ones in there after cleaning them.... the light WINS.... its still ON. as far as the grinding noise goes...its still there... it comes when i turn the wheel to the right and apply light brakes. i looked up other sites for some clues and i learned that the ABS relays could be malfunctioning ... so this week im off to the junkyard and would get ABS relays... lets see if that works. thanks for looking!!
OK fellas.... anyone knows whats wrong with my g20??? any clue??? please help me out here.... would greatly appreciate any help.....thanks again for looking.

Add your comment to this topic!