Klze Wont Hold An Idle


vonage003
04-11-2007, 10:33 PM
:banghead: Hey guys...haven't been around here in a while.
anyway, since the last time i was here i went through about 3 KLZE motors and this would be the 4th one im starting on...i just swapped the thing back into my 1994 ford probe gt and it will start right up but it will not stay running and hold an idle by its self unless i hold the gas like half way.


This to me sounds like a bad vacuume leak am i right? if anyone has any sudguestions or anything at all what it could possibly be please feel free to reply all you want haha. anyway until then i guess what im going to have to do is take off the intake manifold again and see what i could have done wronge and go over everything once over.

Thanks for your help everyone.

got celica?
04-11-2007, 11:40 PM
Yea, it sounds like it could be a vacuum leak. I've recently been working on a KLZE that wouldn't hold a decent idle for the life of it...but it's got problems with the fuel system. We put an adjustable FPR on but didnt realize it until after we put it on and were trying to tune everything in that there was a bad O2 sensor and MAF plus other minor discreptencies. Luckily (or unfortuneately) we are just going to rebuild the engine and start fresh again. Although...thats not necessarily the best option to start with i suppose ^_-

vonage003
04-12-2007, 11:54 AM
well that is one way to go but it was very pricy for my taste. but after the rebuild i had that sucker start right up no problem 1st try...this morot however i bought came with a wierd looking intake manifold that i gave away because it looked so much different than anyone ive ever see i believe it was called the curved neck..and another thing was the a/c compressor did not bolt right up so i had to use the one that came with this car and not hook up my a/c lines. anyway, again im going to try and see further about the vacuume leak deal. thanks alot!

And its not that this motor will start and idle bad...il will start and shut off immediatly unless i hold the gas more than half way!:banghead:

96probegt
04-13-2007, 10:25 AM
:nono: you should of used that manifold with your motor now you can count on a lot of your power gone that paticular style of klze doesnt have any upgraded cams just higher cr and better flowing heads and mani so now you pretty much have a stock motor again .......but yeah it does sound like a vacume leak are you sure you tightened down the intake correctly?? that would be my guess on ur leak

vonage003
04-16-2007, 11:00 AM
its bout time i go take a look at the car now...im going to take the manifold off make sure everything is correct and then torque it down one last time and hope that it stays running on its own. im not too worried about the cams in the motor right now i still have my old cams from my last klze, what i do need is a running car tho so here goes nuthing. ill let yall know how it goes :shakehead

got celica?
04-16-2007, 10:26 PM
this morot however i bought came with a wierd looking intake manifold that i gave away because it looked so much different than anyone ive ever see i believe it was called the curved neck..

:eek:

rhadcundell
04-21-2007, 07:04 PM
i gotta 95 probe and it wont hold an idle either.
i heard it was just the vacuum which im just hoping thats all it is.

<a href = "http://viewmorepics.myspace.com/index.cfm?fuseaction=user.viewPicture&friendID=14695219&albumId=483366">Look at the car..its amazing..lol:naughty:

Add your comment to this topic!