im a girl with a huge problem!


RX7_blues
04-09-2007, 09:46 PM
my 1990 RX7 GTU wont start! heres what happened. I was driving and all of a sudden my lights started to dim and eventually the car stopped. so, naturally, I thought it was the alternator. So I go get the alternator fixed and the darn car doesnt start. We looked at everything (the people who looked at the car weren't rotary experts). because we had no idea what it could be, we concluded it had to be the computer. So I got a new computer and the car still wont start. apparently, the car is getting no spark. What do you guys think the problem may be?

toolfan8102
04-11-2007, 12:34 AM
I'm not a rotary expert either, but the first thing I would check is the Ignition control module, I think they run from $30-90, then check your coil and ground wire.

By the way, does it turn over, or do nothing when you turn the key?

BaLLbOY
04-11-2007, 08:40 PM
i gotta problem and i need a suggestion i wanna buy this rx-7 for like 400$ and they said the only major problem with the car is that its stuck in second gear so what should i do i really wanna buy it but i dont wanna buy somethin i cant fix

toolfan8102
04-11-2007, 11:04 PM
I always steer clear of tranny probs. Don't know too much about them, but it can get pricy.
I guess the best thing to do is get an estimate on repairing it, and then compare the costs if you bought something in good shape.
$400 sounds a little cheap for just a tranny prob though. depending on the year rx-7s are pretty pricy.

drftk1d
04-18-2007, 09:11 AM
probably looking at a new/rebuilt tranny at worst and a clutch problem at best

Adam_rex
04-20-2007, 07:28 PM
well we just bought a motor/tans combo and my friend might be lookin to sell a tranny depending on how things go fro him.

Tim McCreary
04-22-2007, 09:55 PM
my 1990 RX7 GTU wont start! heres what happened. I was driving and all of a sudden my lights started to dim and eventually the car stopped. so, naturally, I thought it was the alternator. So I go get the alternator fixed and the darn car doesnt start. We looked at everything (the people who looked at the car weren't rotary experts). because we had no idea what it could be, we concluded it had to be the computer. So I got a new computer and the car still wont start. apparently, the car is getting no spark. What do you guys think the problem may be?

First you need to determine what problem you have by narrowing it down.

1. Do you have fuel? Can you smell raw gas out of the exhaust?
2. Do you have spark? Pull a plug wire and hook it up near a ground point and look for the spark when you crank the engine over.
3. Do you have compression? Remove one plug in each rotor. Crank the engine over. There should be three distinct "wooshes" coming out of each rotor housing. There should be very little or no difference in the sound. If one of them are quiet, bad side seal. If two are quiet, bad apex seal. Either way a blown motor.

How many miles on the motor?

Email me direct for any other advice at mccreary1@atlanticbb.net

Tim

Add your comment to this topic!