GMC Jimmy Passlock


timski67
03-11-2007, 03:13 PM
After having a new key cylander installed in my Jimmy the System goes through intermittent security passlocl shutdowns. I have tried the relearn multiple times and have waited until the light goes off and have done the relearn, car will rn for a short time than security light will come on.

Occasionally it will shut the car down and I have to wait ten minutes to start a, what is the best way to fix the issues replace PCn and BCm or just purchase a bypass, any other sugestions would be helpful.

Timski67

MT-2500
03-12-2007, 11:16 AM
Welcome on your first post on AF,
What year?
Have you checked for body computer codes?
Any add on remote start or anti theft systems?
Does engine run 30 seconds and shut off?
Is security light on or blinking?

timski67
03-15-2007, 12:18 PM
Thank You

The Jimmy is a 2001, Yes it has been checked for codes and does not show anything. No ren=mote start oar anything was added, has the factory Keyless entry, which has not been working for the last 6 months.

Ocasionally it will run for maybe 10seconds and shut down, this happens very rarely, what happens most of the time is the security light will come on steady(Not Blinking) while i am driving within 10-45 minutes after I start the car. after shutting down, will restart majority of time and same cycle, once in a while it will go into antitheft mode and shut fuel off to the car, so I have to wait 10 minutes for a reset. A new symptom that just started was I have to play with the shift lever to have the car turn over. Still stumped

MT-2500
03-15-2007, 01:54 PM
Thank You

The Jimmy is a 2001, Yes it has been checked for codes and does not show anything. No ren=mote start oar anything was added, has the factory Keyless entry, which has not been working for the last 6 months.

Ocasionally it will run for maybe 10seconds and shut down, this happens very rarely, what happens most of the time is the security light will come on steady(Not Blinking) while i am driving within 10-45 minutes after I start the car. after shutting down, will restart majority of time and same cycle, once in a while it will go into antitheft mode and shut fuel off to the car, so I have to wait 10 minutes for a reset. A new symptom that just started was I have to play with the shift lever to have the car turn over. Still stumped

If the light comes on or engine shuts down the body computer should have body codes set.
How did or what did you check for codes with?
Was it a full engine body capable scanner or just a OBD11 code check?

ponchonutty
03-15-2007, 08:24 PM
I 2nd that it'll have some sort of codes. Next time it comes on, disconnect the BCM plugs which are right next to the gas pedal behind that black plastic. You'll only have to take out 2 or 3 7mm screws to get enough room to access the plugs. Anyway, unplug it and wait about 2 minutes and plug it back in to see what happens.

I was called in at a small repair shop with the same year Blazer with simular problems. They too replaced the ignition switch AND decoder. The only difference was that the security light would stay on even if the car was off. Unplugging the connector(s) to the BCM would reset it. Found out that one of the pins in the plug were bad.

Add your comment to this topic!