91 Accord Speedometer Cluster Problem


jeffragatz
03-02-2007, 03:24 PM
I have a 91 Accord EX Automatic. As soon as it warms up the speedometer cluster goes whacky. The "s" light starts flashing, then sometimes the oil light and check engine light will follow. During this, the speedometer also works intermittantly. I have replaced the cluster twice and the same thing happens on all clusters. HELP!!!

jeffcoslacker
03-03-2007, 05:58 AM
Sounds like an intermittant ground issue....try to isolate the ground wire that comes from the cluster harness and follow it to it's source, see if it's broken or weak...

trw12
03-06-2007, 10:08 AM
I have a 91 Accord EX Automatic. As soon as it warms up the speedometer cluster goes whacky. The "s" light starts flashing, then sometimes the oil light and check engine light will follow. During this, the speedometer also works intermittantly. I have replaced the cluster twice and the same thing happens on all clusters. HELP!!!


I have a 92 and had a similar problem. I had one shop tell me I needed to replace the insturment cluster. I found a Honda tech with his own shop and he found that the plug going to the speed sensor on the transmission was bad. He had an old plug, cut the bad plug off, replaced it with the used one, taped it up and solved the problem.

jeffcoslacker
03-07-2007, 12:16 AM
I have a 92 and had a similar problem. I had one shop tell me I needed to replace the insturment cluster. I found a Honda tech with his own shop and he found that the plug going to the speed sensor on the transmission was bad. He had an old plug, cut the bad plug off, replaced it with the used one, taped it up and solved the problem.

That is a good possibility too. Only thing I can't fathom is the oil light, but the rest of his description fits a VSS reading fault...

trw12
03-07-2007, 03:42 PM
That is a good possibility too. Only thing I can't fathom is the oil light, but the rest of his description fits a VSS reading fault...

Just got off the phone with a factory trained and experienced ex-dealer Honda tech who has his own shop (the same intelligent diagnostician who found the real problem with my speedometer) regarding my oil light flickering, and then flashing intermittently. He believes it's the oil pressure switch which is located just above the oil filter on the back of the motor. The seal(s) inside the switch go bad and it begins to leak which gives the switch false electrical impulses and causes the light on the dash to activate - not to mention also causing a loss of oil from the leaking switch. If you remove the rubber boot/plug from the switch and oil is present the switch is definitely leaking and bad. The oil pressure switch is about a $10 part from the Honda dealer retail and easy to change out yourself or have it done for you.

Add your comment to this topic!