battery will not stay charged


LBB
01-21-2007, 07:30 PM
THE BAttery will not stay charged if your driving the car.

The battery is new, the altinator is new.

It will start up fine, and will drive fine untill the car get's hot about 10 minutes, then it will lose all pull and power.

Any ideas

swimshark
01-22-2007, 01:41 PM
so do you have to jump start the car everytime you start up or is the battery fine? if the car will still start up...it might be a cooling problem. if you do have to jump start your J then it might be something else. post which of these 2 are true and ill be able to diagnose it further.

LBB
01-22-2007, 07:32 PM
THE j will start just fine. And runs fine for about 10 minutes. After that it has little pull to go, the lights go dim.

swimshark
01-24-2007, 10:56 PM
after the car dies, how long do you have to wait to crank it back up? also what voltage is your battery holding while the car is on? it should be between 13.8V-14.6V if you measure with a multimeter. also are all the wires to the battery and altinator secure and attached?

swimshark
01-24-2007, 11:00 PM
also check your ignition and fuel pressure and make sure nothing is messed up with those components

LBB
02-06-2007, 09:30 AM
I took it to a shop,
turns out the altinator that we just got was bad,
even though it was testing good on the machine at the part store. It was barly pulling to get me what I needed.
I had to all so replace 2 of the blets, thye were very worn, so he told me it would be a good idea to do all 3. So that is what i did.

Just wnated to update you guys :)

Speedy_1234
05-28-2007, 12:32 PM
Just a Quick thing THe best way to do if this ever happends again and so you don't have to remove the alter. Just turn on the car then open the hood then remove the neg. cable from the battery if the car does not die then it not the alter. but if it does then it is the alter. This is the thing when you take the alter. to check all the do is add electicly thats it no belt or motor to pull the alter. to the test if you know what I mean
:popcorn:

swimshark
08-04-2007, 10:05 AM
also the battery light will light up if it is a bad alternator. mine did that and i had to replace mine with an alternator from my 97 J30. works fine now but stays on the low side when running. about 13.1 V instead of the recommended 13.5.

Add your comment to this topic!