Stabilitrak Malfunction In 2005 Terraza


MIKE66G
01-05-2007, 11:39 PM
I Have A 2005 Terraza With 20,000 Miles On It. Recenty When The Temp Has Got Cold (30 Degrees) The Service Stability And Service Traction Lights Have Came On. After You Drive The Van ,the Next Time You Star The Van The Lights Are Gone.then When I Have Been Driving Straight On A Dry Road At About 45mph Orr So And Hit A Bump The Van Would Pull And Swerve For A Few Seconds And The Service Stability Light Would Come On.this Has Happened 4 Times. I Took It To The Dealer And They Found 5 Codes But They Say They Can't Help Them Figure What Is Wrong And All They Can They Say They Can Do Is Drive My Van Around Until It Does It Again And Hope They Get A Code That Will Help Them. Has Any One Heard Of A Problem With The Stabilitrak Where It Malfunctions And Pulls The Van And Cause It To Swerve And Be Hard To Control After Hitting A Bump Going Straight? Thanks

MIKE66G
01-09-2007, 11:14 PM
The Codes Were C0253/c0870/c0460/c0196/c0187. I Found Other People On Line Who Had Similar Problems With These Vehciles And Printed Suggestions For The Dealer To Check(stering Wheel Sensor And Frayed Wires). The Dealer Then Found A Green And Blue Wire From The Forward Engine Harness Routed From The Ebcm Underneath The Inlet Air Box Were Completely Rubbed Through. They Rubbed Against The Transmission Bolt. Hopefully This Will Fix The Problem. I Guess You Got To Give Some Dealers Help Finding The Problem With Your Vehicle.

Add your comment to this topic!