Our Community is 705,000 Strong. Join Us.


99 Blazer stuck in 4HI, Wont go to 2HI


Jimmy58
12-13-2006, 09:21 PM
Hi guys, I have read the FAQ. I got a Problem with my Blazer. I put the truck in 4HI for a snow storm and afterwards I tried to put it back in 2HI but it won't go . I have a 4 button switch with Auto 4WD.
Here is what I have done so far. Checked the Actuator under the battery. It looks new and will hold vacuum. The hoses are all in good shape. The switch on the firewall is working and not leaking internally. It is getting good vacuum from the manifold. The switch on the front Axle is working( checked with a multimeter). I removed the battery cable for about an hour. With the truck not running and the passenger side wheel jacked up I can spin the wheel. When I start the engine the switches on the dash all come on momentarily and then it will light the 4HI button. I cant spin the front Pass. wheel. This leads me to believe that the actuator and the switch on the fire wall are working.
When I attempt to switch it into 2HI The light on the 2HI button will flash for about 10 seconds and then it will revert back to the 4HI button. I can hear a whir and some switches clicking but it dosn't seem to do anything. I assume the transfer does not need to switch gears when you go from 2HI to 4 HI . When you go from 2HI or 4HI to 4LO the encoder should run. Do I have this correct? Any help will be greatly appreciated.
I also checked the ground wires from the tccm to ground and I do have a good ground. Thnaks and sorry for long post.

JaVeRo
12-14-2006, 12:32 AM
It looks like you have covered almost everything. I'm not familiar with the 4 button Auto 4wd. One thing you might check, with the engine off you said you could spin the front wheel. Try turning the driveshaft.

It sounds like the transfer case is not disengaging but since the front axle is vacuum controlled, It will disengage when the motor is not running. The only thing that turning the driveshaft will tell you is whether the transfer case is staying engaged or it is engaging everytime you turn the key on.

James

muddog321
12-14-2006, 05:06 AM
Pull the vac line off that firewall solenoid and see if the front actuator disengages - some solenoids do not shut the vac off and act stays on. Then check the sensor on the front axle and see if it works - ball switch so take it out and push it in/out and see if it goes to 2wd. Check for cut/ripped wires running to the transfer case up on the drivers side a big bundle and if they drop can get damaged especially if the transfer or trans ever taken out. Then pull the battery cable for 30 min OR the ATC and 4wd fuses to reset the TCCM.

Jimmy58
12-14-2006, 06:05 PM
Thanks for the input guys. While the truck is not running and has been off for a while the actuator under the battery is in the unlocked position. When I start the truck it goes to the locked position. I removed the switch on the cable housing going into the front differential and tested it with an ohm meter and it switches states when I manually depress the ball on the end. There is power to the switch.
Is there a way to test the motor on the transfer case to see if it is working correctly? NOT used to working on electronic 4 wheel drive. Is there a way to test the tccm? when I push the 2HI button how should that affect the power going to the TCCM? I checked the wires to the transfer and all look good. no shorts of pinched wires. I pulled the connector and it is clean and dry. Looks like either the encoder motor or the TCCM.
Thanks for the help. Would love to change this to a manual system. Lot less hassles.
Nick

JaVeRo
12-15-2006, 12:04 AM
I removed the switch on the cable housing going into the front differential and tested it with an ohm meter and it switches states when I manually depress the ball on the end.

The switch on the front actuator cable really has nothing to do with the front actuator engaging. All it does is control the lights on the dash. When the axle is engaged that switch tells the lights to show 4wd, when it is not engaged the switch tells the lights to show 2wd. It's actually more complicated than that and you may have already known that, just wanted to be sure.

Something is causing vacuum to the front actuator when it shouldn't. I'm not familiar with the 4 button auto 4wd. Jack up one front wheel with the engine running, If the wheel doesn't spin then your transfer case is engaged. If the wheel and the driveshaft spin then it may be the vacuum switch on top of the transfer case. If it's a problem with the transfer case or tc motor, that is over my head.

James

muddog321
12-15-2006, 05:55 AM
4button NP236 case - sure points to that firewall solenoid. So to pinpoint pull the input vac line off the solenoid and plug it (golf T or something) and start the Blazer - no locked front actuator - then connect the line back in and it locks up points to internally bad solenoid - about $45 at dealer and 1 min to replace so ....

JaVeRo
12-15-2006, 10:56 AM
4button NP236 case - sure points to that firewall solenoid. So to pinpoint pull the input vac line off the solenoid and plug it (golf T or something) and start the Blazer - no locked front actuator - then connect the line back in and it locks up points to internally bad solenoid - about $45 at dealer and 1 min to replace so ....
Does the NP236 still have the vacuum switch on top of the transfer case? What tells the solenoid to engage the front axle?

I'm trying to learn something here so maybe I can quit giving people bad advice. It appears the 233 and 236 transfer cases are much more different than I thought.

James

Jimmy58
12-15-2006, 06:43 PM
I have checked the switch on the firewall using a vacuum pump and and a
12v power source. with the source hose from manifold and the hose that runs to the actuator removed I applied vacuum to one side of the switch with pump. It held vacuum for 5 min. Not leaking through. I then applied vacuum again and then hitched the solinoid to a power source and the vacuum was dumped. I believe this switch is working perfectly.The actuator will release the front end when there is no vacuum( confirmed by spinning right front wheel). when I apply a vacuum to the actuator it locks the differential ( again varified by trying to spin front right wheel). ATV and 4WD fuses are good. With key in the off position I have no power on the solinoid on firewall. When I put it to run I get power instantly. ( again the buttons on dash show it is in 4HI). The switch on the front Diferential has been removed and tested manualy with an ohms meter. Tests good.

The mechanical side of the equasion seems to be doing what it is told ( signals sent from TCCM) What I need to know is if there is a way to test the TCCM and see if it is working correctly. The Autoxray scanner I have wont read the codes from the trans and transfer. Also I need to find out if there is a way to test the encoder motor and see if it is working correctly? When I say test I mean removed from the blazer.
Thanks everyone for all the help. Most times people have problems going into 4WD not coming out. If all else fails I guess I will change the TCCM and the Encoder motor.

Dougaroo
12-15-2006, 08:56 PM
I have the same problem.
Can only get it out of 4 high by pulling the fuse (under hood)
Replaced the TCCM. Still stuck
Replaced the dash switch still stuck
Just replaced the the vacuum acuator switch. Still stuck.

I did notice I could engage and disengage the front drive bypassing the valve and hooking up the vacuum hoses direct. This means the vacuum acuator value is being continously energized and engaging the front drive. I can hear the encoder motor work when I push the dash switch.
Sooo...A short somewhere?
DOUG

JaVeRo
12-16-2006, 01:00 AM
Jimmy58, you have mail.

Jimmy58
12-22-2006, 11:33 AM
EUREKA!!!!!! Found the Problem with the Blazer. After testing all of the components involved with the 4 wheel system I couldn't find any problems...
I finally decided to pull the encoder motor to see if I could shift it manualy to make sure I didn't have a mechanical problem and found the problem. Looking at the encoder motor from underneath It looked almost new. I pulled it off and found a major build up of corrosion between the plastic gasket and the motor gearbox. So much so it distorted the gearbox and bound up the unit so it wouldn't complete the shift. I scraped all the corrosion off and it had a very pronounced bow to the unit. I pulled it all apart ( I'd like to kick the engineer that decided to put security torx bolts in the cover) and seperated the 2 halfs. I checked the machined surfaces with a straight edge and found that the housing was warped by at least 3/16th of an inch. I figured nothing ventured nothing gained so I pulled the unit completely apart and using a press straightned the 2 halfs the best I could. I then used a big mill file and flattned the two halfs so they were true. While I had the unit apart i checked the brake unit on the end of the motor and it was fine except that there was some gunk on the friction plate so I cleaned it off. I checked the motor and found one of the stabs for the power feed was almost burnt off. I cleared away some of the insulation and soldered the wires directly to the motor feed wires. No chance to loose continuity again.
I reassembled the unit and installed it back on the transfer case, installed the driveshaft and lowered the truck to check the shift modual connections.
After connecting the modual I replaced the fuses and started the truck. Bingo the truck snapped into 2HI and works like a champ now..
Sorry for the long post but thought you guys would like to have the info.
I checked with the local stealer and (IN New Brunswick) he gave me a price of 843.00 can for a new motor. I DON'T THINK SO!!!!
Thanks everyone for your ideas
Nick:uhoh:

Dougaroo
01-02-2007, 03:28 PM
Problem solved. It was a severely corroded encoder motor. I took it off the T-case and found incredibly heavy metal salt deposits between the encoder case and the T-case. These deposits formed from road salt that leaked between the plastic spacer. Corrosion was so bad it warped and split the encoder case and broke the metal along one of the anchoring bolts. The plastic spacer was deformed. I took the unit apart and found rusty water in the gear assembly. The electric motor was also shot, as water leaked in from the wire connection, which in turn filled the motor casing with rust. Finding a new encoder motor is hard. They are back ordered everywhere, even on Ebay. The dealership has them but will hose you for $800 plus. I finally found a rebuilt one for $150 that had to be ordered in from Chicago. I was able to heat and press the spacer back in to shape and then sealed it to the encoder case with blue gasket material to prevent future rust. Exercised the T-case shift spline, which was fine. Reinstalled the motor and bingo, everything work great. I got my two and four wheels back. Sweet. A PM word to the wise for those with 1999 S10ís in the snow belt, check your encoder mounting before itís to late.

Jimmy58
01-03-2007, 08:06 AM
Hi Dougaroo, Isn't the encoder motor setup poorly designed. To build these things out of Magnesium is very short sighted. Maby if they made GM engineers work on these systems they would come up with better ideas.

Well enough P and M glad to see your prob is found.
Jimmy58

Add your comment to this topic!