Blinker Shuts off Engine


brian_k24
11-28-2006, 11:18 PM
I have a 1999 Regal LS that just started doing something strange. When you turn on the left turn signal it shuts off the car, all the lights on the dash and the radio go off but the headlights stay on. It will turn back on in a second or two then you can restart and it runs just fine. It will do this for 5-10 uses of the left turn signal then the next 10 or so times the turn signal is used it will not shut the car off. A few times the "Service Vehicle Soon", "Anti Lock", "Trac Off", and "Service Engine Soon" lights all came on at the same time and then would go off. These problems all started at the same time a couple of days ago. Any help on where to start.

BNaylor
11-28-2006, 11:53 PM
Welcome to AF.

A good starting point would be the multifunction switch and the ignition switch and harness assembly at the steering column. There is a 12 volt feed from the ignition switch to the multifunction switch. But it sounds like you have some bad contacts in the ignition switch.

Also, make sure the battery and alternator are good. Check output and the connections/cables to battery positive and negative to include grounding.

brian_k24
12-02-2006, 10:56 AM
Thanks for the help. I was think ignition switch or harness until all the MILs came on then had doubts and started thinking bigger problem. After your post went back to looking at switch and sure enough 4 out of 6 contacts had carbon deposits with 2 of them being completely covered. Cleaned the contacts and car runs great with no problems. Switch is really pretty simple and easy to disassemble and reassemble, the only thing that is tricking is getting the spring that pushes the key out of the start position and back to the on position in the correct location.

mwm
01-09-2007, 01:36 PM
was it the multifunction switch or ignition?

BNaylor
01-09-2007, 01:51 PM
was it the multifunction switch or ignition?

Post #3 was referring to the ignition switch.

mwm
01-09-2007, 01:53 PM
Okay thanks alot im having the same issue right now, car shut off when the blinker was turned on

DragonsGirl
01-09-2007, 04:45 PM
Replace your ingine switch it worked for me

Add your comment to this topic!