Page updated on 06-21-2018

97' Cavalier Help plz!


CoreyJ
11-21-2006, 03:16 PM
I have a 97' cavalier! Recently it has been sounding as its running loud. And the gas pedal felt like it was vibrating. Well today I came to a stop sign, when I gave it some gas it acted up! It was a on/off reving sound! I was going barely anywhere! Pedal pressed and getting no acceleration! Just the consistent on/off reving! The engine light also insantly came on! Thankfully I was only a couple blocks from home. When I turned the corner to head home after a block of coasting, it sort of kicked back in! Not like it should be but I was able to accelerate again. I pulled in drive and shut it off! I noticed a burning like smell from the engine! Fluids are all fine! Can someone plz help me. Thank you!

CoreyJ
11-21-2006, 03:21 PM
sry bout it posting several times! I dont know what happened there!

CoreyJ
11-22-2006, 06:27 AM
Does No one have any ideas or what? I really need some help, can some1 plz take the time to give me a hand! Thank You!

CoreyJ
11-22-2006, 07:10 PM
wow several views no replies! Does that mean its bad or just no one has a clue what it could be?

owenl
03-01-2007, 03:42 PM
when my 2.2 97 did this it was the trany going bad.
u might want to check that out first.
i took mine in right in time all the gears blew out when they test drove it to find the problem.(they had to push it)
but yeah check or get the trany checked.

jackson5rules
03-27-2008, 04:13 PM
my cavalier did that too for a while it would barely move then all of asudden it would be back to normal so i changed the spark pulgs and wires an she runs like new again!

Add your comment to this topic!