Trouble Shifting out of Park


tempfixit
10-30-2006, 08:58 PM
A friend of mine has a 2001 Rio, Automatic Tranny, 96K miles. Lately she can not get it to shift out of park. SHe let it sit for a couple of days and it shifted. Now she does not use park anymore. Any ideas if this is a sensor or relay problem???

Thanks for any advice,
LS

Homewood50
01-28-2008, 06:57 PM
Ihave an 03 Rio RX-V. It sat for a while until the batter went flat. Couldnt shift it out of park because solenoid requires power. Used the little mechanical disconnect next to the gear selector but it still wouldnt move. It had been stiff a number of times before this, and sometimes almost had to wrestle it out of park. By the time it reached the service station the park/brake interlock pin had completely seized in place and this was holding the transmission firm in Park. Service had to drop the pan and attack the seized pin from the inside until it freed up, it was corroded in place and they told me it had probably been stiff to get out of park for some time and then when i let it sit for several months that was all it took for the two surfaces to practically weld themselves together. The pin had to be machined a little and then put back in place I was told to run the vehicle regularly and ensure ATF is fully topped up because warm fluid is required to lubricate this pin. Could this be the start of the same problem for you?

robbie789
08-08-2009, 08:44 PM
on top of the tranny you with see where the connection for the gear select lever and input shaft that goes into the tranny spray the shit out of it with wd-40 or penetrating fliud then work it back and forth continue and keep spraying.

Add your comment to this topic!