Page updated on 05-23-2018

instrument panel not working


joshua43130
10-26-2006, 09:11 PM
I had to change the battery in 02 cavalier. After changing the battery NOTHING on the instrument panel works(gas gage-mph-odometer etc...) Called dealer, they said to hold the battery cables together for 30 seconds to restart computer. Didn't work. Any suggestions.:banghead:

Evilmonkey1177
10-27-2006, 12:43 AM
Did you check the fuses?

homerr
10-27-2006, 06:57 AM
I had the same problem after taking out the battery to replace the upper rad hose (go figure). All I did was disconnect the ground wire on the battery and hooked it back up and all was back to normal.

Homerr

joshua43130
10-27-2006, 07:25 AM
I did check the fuses. I will check the ground wire and let you know. Thanks:)

joshua43130
10-30-2006, 07:43 PM
I finally tried to unhook the ground wire. Well, some of the lights come on but they stay on with the key off(service engine, water, etc.) Still no gas gage, mph, odometer etc. Any other suggestions?

jakegday
10-30-2006, 07:57 PM
try leaving the battery completely disconneted overnight, it might not work, but its worth a try

T_rev87
11-04-2006, 07:18 PM
I had to change the battery in 02 cavalier. After changing the battery NOTHING on the instrument panel works(gas gage-mph-odometer etc...) Called dealer, they said to hold the battery cables together for 30 seconds to restart computer. Didn't work. Any suggestions.:banghead:
check ur fuse

T_rev87
11-04-2006, 07:19 PM
check ur fuses

Add your comment to this topic!