Our Community is 705,000 Strong. Join Us.


91 crx si w/ b16 swap, has problems, help me please


jedmo91crxsi
10-14-2006, 02:26 AM
i have a 91 crx si with a jdm b16a1 swap thats been giving my sometrouble lately, and i was wondering if anybody might be able to give me an idea of what might be the problem or problems.

Anyways, here are the problems....

first off, when i try to start the car, it sometimes wont start right away, like it takes a minute to fire up, where as it used to fire right up all the time. it does this when it's cold and hasnt ran for a bit,

secondly, when started and while just idling, it will surge and never stays at a steady rpm, usually goes from like 600 to about 1500 rpm's or so.

thirdly...it tends to run hot, well, the temp will go from normal to almost in the red then back down to normal to barely above half back to normal back up to the red sometimes stay there for a few min then back down to norm... i'm not too sure, but to me it seems that sometimes if its close to the red and i rev it up some for a sec it will cool back down... i dont know what's goin on...

fourth... sometimes it will smoke from the exaust, a white kind of smoke and smell like antifreeze, the heater inside the car also smells of antifreeze, so yeah...

and finally... the vtec does not work anymore, no clue why or if any of the other things have anything to do with it...

if anybody might have any ideas as to what might cause these sorts of things, i'd really appreciate it if you could help me out..

thefooshmeister
10-15-2006, 12:13 PM
hmm could be a number of things, id look at your fan and see if its coming on. sounds like your fan switch might not be hooked up correctly and that could explain the overheating. when the needle is goin crazy like that the last thing you want to do is rev it cuz if it really is runnin hot you could fry some internals and i doubt you want that. the surge at idle is most likely from a vacuum leak so check your lines around the intake manifold and see if theres any leaks. the vtec coming on is your least bit of problems right now id say so troubleshoot the other problems and once your engine is running correctly see if it comes back on. also check your ecu underneath the passenger carpet and see if its throwing any codes. refer to the sticky in the 4th gen section or search on here to figure out how to read them

hondacivic99sivtec
10-15-2006, 01:02 PM
why did you poat this in different places? taking up space?

Pavlo
10-27-2006, 02:29 PM
first off, when i try to start the car, it sometimes wont start right away, like it takes a minute to fire up, where as it used to fire right up all the time. it does this when it's cold and hasnt ran for a bit,

Many civics do this when the gastank is below half.

secondly, when started and while just idling, it will surge and never stays at a steady rpm, usually goes from like 600 to about 1500 rpm's or so.

Vacuume leak, idle control unit.

thirdly...it tends to run hot, well, the temp will go from normal to almost in the red then back down to normal to barely above half back to normal back up to the red sometimes stay there for a few min then back down to norm... i'm not too sure, but to me it seems that sometimes if its close to the red and i rev it up some for a sec it will cool back down... i dont know what's goin on...

Thats what my car did when my thermostat craped out, so try this first.

fourth... sometimes it will smoke from the exaust, a white kind of smoke and smell like antifreeze, the heater inside the car also smells of antifreeze, so yeah...

Cracked head, block, or headgasket, that allows coolant to get to the cylinders.

and finally... the vtec does not work anymore, no clue why or if any of the other things have anything to do with it...

If you have any CEL on then VTEC won't work.



Check for vacuume leaks, replace the thermostat (only $15), do a compression check, so that you know if any particular cylinder has low compression then take the head off and inspect everythings for cracks and replace the headgasket. Your coolant is probably leaking because you overheated it and either destroyed the hg, or cracked the head. Good luck.

JJEx22
11-27-2006, 12:19 AM
Check The Cylinder Head There Might Be Leak!!!!!!!!!!!!!!

Add your comment to this topic!