94 Corsica 3.1L, engine dies


GTwreck81
08-18-2006, 06:37 PM
I have problem with my '94 Corsica 3.1L where the engine dies randomly at certain times. Either

1) When starting, it cranks and the engine starts, but then immediately dies.
2) After starting, it cranks and idles for a few seconds, then dies. Sometimes it is sudden, and sometimes the RPMs audibly fall maybe a second before it dies. If I can hear the RPMs falling, giving it some gas keeps it alive though sometimes after releasing the accelerator it dies after returning to idle.
3) Sometimes it dies suddenly when idling at a stop or at slow speeds.

The problem started a couple weeks ago and is progressively getting worse, with first (1) appearing, then (2) and most recently (3). Sometimes it starts and runs perfectly fine for hours, and sometimes it's a real pain in the arse dying in traffic and all sorts of fun stuff....

When any of these happen, the SES light may or may not come on. Each time, after at most a few attempts at starting, it will turn on and run ok. It's not giving any problem at moderate to highway speeds.

Any ideas on what could be causing this and how I could localize the problem? Any help would be appreciated.

jsgold
08-18-2006, 08:36 PM
Need the codes your car is setting when the check engine light is coming on first. Just beacuse it does not stay on it is still setting trouble codes and storing them. A sensor most likley has bit the dust, maybe EGR, MAP sensor, hard to say what else. Could even be a bad computer as they can go bad but get the car scanned or do it yourself. At the end of this is a Corsica forum that has directions for this, or, you can buy a 20-25 dollar tester with book at Advance Auto. Then compare codes and report back. Sometimes one thing can trigger a code on another thing so you have to do tests to rule out stuff. A TCC going bad will cause a lot of what you mentioned, but it would only do it in gear and will not usually set a code. get the codes, report back so we can give you options. Might want to invest a few bucks in a Haynes manual for your car also...http://www.corsicas.com/

GTwreck81
08-19-2006, 09:10 AM
I got the error codes checked at Advance, and it said

1) MAP sensor signal voltage is too low
2) Transmission torque converter slipping

so your hunch about a MAP sensor biting the dust may be right. Could the transmission torque converter also be involved in my car's problem or is that a separate issue? I know that my transmission fluid is in need of a change...could old or low fluid cause that slipping or is it more likely a transmission component wearing out?

jsgold
08-19-2006, 05:36 PM
I would not be too concerned about the slipping code but would get a fluid/filter change at some point. My son's 94 Beretta(same car, just slightly diff. body style) had this too once. After clearing it never came back. If it comes back again maybe a problem though. Sounds like the map sensor has bit the dust to me, but I would check all vacuum lines in the engine area, especially the one going to the MAP. Get a haynes manual too, there are a number of tests you can do to try to eliminate other items but I no longer have the 94 GM manual we had for the Beretta (they used same manual as Corsica). Most likely you will have to replace MAP and perhaps some old vacuum line as well. A MAP will cause stalling and poor performance when it fails.

GTwreck81
08-21-2006, 08:59 AM
Hmm yeah I have a GM manual for the Corsica, though I might get a Haynes as well for the excellent troubleshooting instructions that the GM seems to lack (had one for my old Honda Accord and those helped out a lot). After I check the vacuum lines (yay for Advance renting vacuum testers for free for 45 days) and MAP sensor (replacing if faulty) I'll report back whether it fixed the problem or not.

Add your comment to this topic!