1996 Dodge Neon Transmission


BarneyGeo
08-10-2006, 09:34 PM
Car has been running great. Yesterday my daughter said the car started to slow and shake and stutter while the engine was showing no problem with running (no dragging down engine.) I drive it today and after about 5 minutes of running I got the same thing. It was like it would not pull but the engine was fine. I could stop it and it idled fine with no missing. As long as I was moving it was shaking or slipping like bad trannys do. BUT while its cold there are NO indications of problems.

With no previous history of tranny probs could I have a stopped up filter system out of no where? If so where is this filter located along with the screen pan to change out. Would this do any good.

All help is greatly appreciated. The wife wants to scrap it and I dont think it is ready!!! Please help me prove her wrong! We all know how goodl that feels!!!!!!!!!

Thanks again,

BarneyGeo

das2123
08-11-2006, 07:41 AM
Did you check the fluid level? Have you added any fluid lately and if so what kind? When was the last time you did a fluid and filter change?

BarneyGeo
08-11-2006, 08:12 AM
Check fluids regularly. I am doing a fluid filter change today to see if that helps.. Any other suggestions welcome. Did a lot of reading on the forums last night. Could be wrong type of fluid possibly.

Thanks again,

BarneyGeo

das2123
08-11-2006, 10:41 AM
Mopar ATF+4 is all you should be putting in there. If you have ever use Dexron/Mercon ATF, your tranny will make you pay!

BarneyGeo
08-11-2006, 01:24 PM
just finished test driving after fluid and filter change. Much better but when starting out in first it is still a little draggy. If I step in to it the car will go on with no problem. Havent really driven tons of miles to see if the 1st gear will corrector if others will start back.Also, did not change out fluid in cooler just lower unit.

Any other suggestions to get that first gear running correctly shy of changing the tranny?

das2123
08-11-2006, 01:27 PM
Did you adjust the kickdown bands also?

BarneyGeo
08-11-2006, 02:07 PM
No, that I do not know how to do? Any help is appreciated if it will work!! Please so,me one send some instructions or a link to a post. I cant find one. What will this help exactly?

das2123
08-11-2006, 03:12 PM
I posted it in this thread...
http://www.automotiveforums.com/vbulletin/showthread.php?t=476823&highlight=kickdown+band

BarneyGeo
08-11-2006, 07:37 PM
Tried to do the kickdown. Got battery and fusebox out. could not figureout what to tighten. I did not see wing nuts. To the left I saw cables that looked like throttle cables. Under that not much I could Identify except the tranny pipe going down.

Thanks for the help! Any suggestions? Can you describe what I am to adjust PIC? What does adjusting the kick down do , will it adjust the jerking?
Thanks!!!!!!!

Add your comment to this topic!