code 42, bubbles in radiator


rknorr
07-18-2006, 12:57 PM
89 Cavalier with 46,000miles. 2.0 TBI

Car showing a 42 code since yesterday. Car lost all coolant after heater core split. Replaced heater core and was running cooling system flush through cooling system with radiator cap off and foam continuously came out of radiator neck. I filled radiator to top to eliminate room for foam and could see bubbles continuously coming out of radiator core. Car never overheated before heater core replacement, just happened to notice radiator was empty. Blown head gasket or cracked head possibly. Don't know how long car was driven without sufficient coolant. How do I check without removing the head to check. No water in oil either, at least not yet.
Code 42 showed up yesterday when starting car to drive it up on ramps, I have been having intermittent poor acceleration problems sometimes accompanied with an occasional misfire. Have replaced the TPS, spark plugs, fuel filter, air filter and MAP sensor for poor running / starting problems which the TPS fixed with the exception of the occasional poor acceleration / misfire. My Chilton says that code 42 is Electronic Spark Timing bypass circuit grounded. How do you go about troubleshooting this?

rknorr
07-18-2006, 03:35 PM
update: I don't know why but when I flushed the cooling system with clean water and put in antifreeze the bubbling stopped so maybe I got lucky and nothing is damaged AND the 42 code went away. Only thing I did was do a compression check, all cylinders were between 170 and 175psi. Still got the occasional reluctance to accelerate problem though.

rknorr
07-23-2006, 11:15 AM
The code 42 is back accompanied with misfire and hesitation during acceleration, when running at a steady speed you can feel the engine isn't running right like it has a slight misfire then too. I'm thinking the DIS module might be bad, what do you all think?

Young Chuck D
07-24-2006, 04:43 AM
The code 42 is back accompanied with misfire and hesitation during acceleration, when running at a steady speed you can feel the engine isn't running right like it has a slight misfire then too. I'm thinking the DIS module might be bad, what do you all think?

i don't know but i have the same car as you and i get a bit of hesitation when i push the pedal unless i floor it from zero... TEMP light comes on once in a while on high speed long trips...

anyway whats 42?

Add your comment to this topic!