Our Community is 705,000 Strong. Join Us.


OK, I'll start


ilgoldstein
07-01-2006, 07:32 PM
I had a 84 Celebrity I bought in the fall of 85 from Avis's lease division. It was a good solid car. Except for premature transmission failure at less than 90K and two more trans failures I blame on poor rebuilds, the car was very reliable. Bought it with less than 18K and drove it well over 200K.

broughy84
07-09-2006, 09:29 AM
I had a 85 Celebrity Euro. It had the standard 4 banger and it had a four speed manual. I bought it for $300 about 3 years ago. Put tires on it and a new rack and pinion steering and drove the hell out of it. Sold it for about 700 last year. Not a bad car, I wish I would have held onto it now that I'm driving farther back and forth to work!

tractorboy
07-10-2006, 03:08 PM
I had an 89 celeb eurosport, V6 2.8L.( last year for the sedan) Bought it new. Very reliable car. The interior reminded me of the family car back in 1971. Which was a Dodge Dart swinger. Traded the car in on a new 2003 Impala v6 3.4L . When i traded in the celeb it had 80k, did not drive it much ,had a company car. The celeb ran like the day I took delivery. Had a slight trunk water leak, that i think was coming from a seam.

richtazz
07-15-2006, 02:20 PM
my 87 Celebrity wagon had 250k on it when I sold it to a girl I know. She had gotten it to over 425k when a guy pulled out in front of her and totalled it. It was a 2.8 v-6 and 4 speed auto, and was still getting 30+ mpg on the highway and running perfect when she smashed it. The motor and trans had never been out of it. Regular maintenance, one starter, one alternator, an oil pump drive o-ring and valve cover gaskets are all that were ever done to it.

666_speed
07-24-2006, 12:13 AM
Never owned one, I looked at one once at a car lot though!

my99cavy
07-24-2006, 08:10 PM
unlce use to have one. back in the day. never really liked the thing.

broughy84
07-25-2006, 05:34 PM
I really do miss mine....The only problem I had was the ignition module went out once

666_speed
07-26-2006, 12:12 AM
The one I looked at had a push button start. Had only 26k original miles.

my99cavy
07-26-2006, 01:04 PM
The one I looked at had a push button start. Had only 26k original miles. push button ignition on a celbrity huh?? did it have anything else dont to it??

666_speed
07-26-2006, 10:07 PM
It had a cd player built into the dash. It had pinstripes around it that were dolphins, kinda gay. It was a light tan color. They wanted $800 for it haha.

nutsony
07-28-2006, 07:39 AM
Have an 87 with 89k miles. Grams car I inherited last year. It sat in a garage for 4 years. I Put about a grand into it, tune up, tires, shocks springs, struts, muffler. My dad said it would stall occasionally but up till now it has been fine. 3 times on the way to work yesterday it stalled as I slowed down, it will surge as it shifts now and never did that before. Couldn't get it to stall today but it still surges when I am light on the throttle. I would guess it's the TPS but i have no error codes and no ck engine light. No loose connections. Weird thing was when I tapped the MAF sensor with a screwdriver it quit. I actualy squeezed the MAF between my fingers and it quit. I know it works on a varying frequency but this doesn't seem normal to me. I'd hate to buy one if it doesn't need it. V6 2.8 port Fuel Injection. Anyone have this problem before?

450HP
09-09-2006, 08:03 AM
nutsony, try finding one at a salvage yard... they're pretty cheap and if it works better for you,
you can either replace it with a new one, or leave the used on on till it acts up.

Scott

DeViL
10-26-2006, 11:25 AM
My commuter is an 83' Celebrity. For a crappy old carb v6 it gets damn good gas mileage. Only maintenance I've had to do with it was replace an altenator this past september. I have over 90k miles on it.

Scrapper
11-04-2006, 07:40 AM
you can also take that MAF apart clean the screen and put it back together...cant say how long it'll last you tho....

|WYG|SS
11-13-2006, 09:20 PM
my bro has 85 celeb (i think) well he bought it from our grandpa and it ran fine but the bad thing is that where my grandpa lived they dumped salt on the road alot becasue of snow in winter and it just rusted the hell out of it. hell u can see the inside of the car through the bottom of the doors. untill oneday my dad was driving it out at his work and some semi truck the hauled woodand stuff rear ended him and shifted frame forward and now with the rust it actually rusted the frame and the frame let lloose on the back tires where it is meant to be at and now it just boobles around. he doesnt drive it anymore. it had to get a new head on it becasue the engine started on fire once when filling it up with gas and the exhaust fumed leaked into the passenger compartment, but yeah i think they are good cars.

Steamengine4450
05-20-2007, 03:13 AM
WOW!!! I have two Celebs right now. One is an 85 sedan white over fern green. The other is a 87 sedan fern green over fern green.
The 85 has a kinda clunky fuel injected four banger.
The 87 has a real nice fuel injected V6. That car is great!

I used to have an 89 with a four banger. It was much nicer. I had it for 8 years! Sold her last year for 800. Kinda miss that car but it was warn out and I had the 87.
Got the 85 in October of last year. Just got it because I desided I wanted a second car. But not as happy with it as I was with my 89. Seems they reworked the four banger (Iron Duke) between those years.

Add your comment to this topic!