Turn Signal and Headlight electrical issues


automotivenovice01
06-04-2006, 05:46 PM
The headlights kill the battery charge. I have replaced the alternator and the battery. When the alternator is tested it checks out ok until I turn the headlights on. I know some drop is normal with the headlights operational but it goes from about 14 to 10 volts. I have replaced the alternator twice, checked all the bulbs and nothing seems to be wrong. The voltage regulator is supposed to be in the alternator. I suspect a dead short somewhere but if it could be something easier then let me know.

This probably is irrelevant but the turn signals are also out of order. The blow the fuse immediatly. All the bulbs are ok. I tried using a 25amp fuse instead of the 15 and it also blew.

Sgt Mack
12-21-2014, 02:54 AM
NEVER exceed the stock amperage!!! Instead, you might replace w/ a circuit breaker, which may give you time to isolate the short. Had similar problem w/ a Ford van. Got my 1st exposure to circuit breakers, as I was able to get from the fuse box to the shorted wire, as the fuse re-set and it sparked. Folks had similar problem w/ Plym. Sapporo. Replaced the fusible link w/ breaker, as neither the shop nor I could find the intermittent short They just had to pull over when it died and wait for breaker to re-set.
Not a good fix, but better that a kick in the head or poke in the eye w/ sharp stick. Good luck & if you find any solution for power thru signal fuse, but not at flasher relay, I'd appreciate it.
Sgt. Mack

byrddog
04-15-2015, 10:11 PM
The headlights kill the battery charge. I have replaced the alternator and the battery. When the alternator is tested it checks out ok until I turn the headlights on. I know some drop is normal with the headlights operational but it goes from about 14 to 10 volts. I have replaced the alternator twice, checked all the bulbs and nothing seems to be wrong. The voltage regulator is supposed to be in the alternator. I suspect a dead short somewhere but if it could be something easier then let me know.

This probably is irrelevant but the turn signals are also out of order. The blow the fuse immediatly. All the bulbs are ok. I tried using a 25amp fuse instead of the 15 and it also blew.
sounds like u r on the right track. the head light plug is suspect. that is the groung out and is hard to see it with out it completly removed. like the other guy said,DO NOT INCREASE THE FUSE AMPERAGE, THIS CLOUD LEAD TO AN ELECTRICAL FIRE, or short out the stalk switch. try taking both headlights out. put an ohm meter in the outlet, set it to continuity you should get almst a 0 reading

Add your comment to this topic!