97 Cav misfire


mtech91
06-01-2006, 11:31 PM
Ive seen similar problems listed here but want to find out if anyone recognises this one!
Ive a 97 Z24 and it feels like it is misfiring/spluttering at 1500 to 2500 rpm, hesitates or coughs when i accelerate but is fine when im into the higher rev range Its really bad at idle when i put the AC on, it cant cope and nearly stalls. No codes have appeared and the MPG is high. can anyone help!

Moody Blues
06-02-2006, 12:08 PM
Don't know if this is your problem, but figured I'd throw it out there. My wife has a 97 Cavalier LS w/ the 2.4L (same as the Z24 engine if I recall) about 120,000 miles. I wasn't here when this happened so I only know the story. She had been griping about if running rough and stalling. Her father put in a new set of plugs and managed to start a small fire (DON'T ask me how) Anyways, they took it to a mechanic he knew of, and the guy said it was the coil pack, which is located under that cover over the top of the engine. Replaced it, and the car seems to run much better, although we still have an emmissions code problem (asked about in another post)

Anyway, my point is, you may have a bad coil pack. This mechanic said they go often enough that he keeps the pack on the shelf. Part was about $100 (I think) Make sense to me scince this pack is stored between the camshaft housings, a pretty hot spot. In my experience, coils and heat equals premature failure.

I wish I has been around for this problem fix, as it would make me more sure of this advise, but like I said, the stalling, running rough has gone away.

Add your comment to this topic!