ext. temp gauge reading -22 why? in my e30


318isboy
04-25-2006, 11:00 PM
hey, this is my first time posting a thread, but i need some help, i love e30 3 series and my 318is is my second one, but wen the battierie was disconnected on it the temp. gauge on the OBC is reading -22 degress and i dont know why, i think i need to calibrati it or sumting, maybe im missing the module that takes the temp readings.... i dunno can anyone help me out with this?:banghead:

Bear
05-04-2006, 09:11 PM
Battery disconnect should not do this (are all of your other OBC readouts correct). The sensor probably has a broken wire (sensor is in lower air dam, drivers side and it pokes out through a small hole). Check the electrical connection for a broken wire at the connection in the air dam sensor.

318isboy
05-05-2006, 08:35 AM
hey,

thanx for the info ill go chec that out right away

Bear
05-05-2006, 08:53 AM
Please let us know if this works. I had to rebuild the electrical connector on the sensor at the air dam as it had just crumbled. I disconnected the plug, cut the wires aft of the sensor and went to auto parts store and bouhgt a pair of male/female bullet style connectors. I crimped the female connectorns on the cut wires and then slid the females on the male portion at the sensor and all was back to normal.

318isboy
05-05-2006, 09:01 AM
hey do you think it would be easier to go to a junk yard and snage the sensor and cut off a good amount of wire? because i tihkn i can do that, threes a junk yard near my house. oh yea.. do you know of any places online where i can get the sport seats, the one in my car is broken, and imcontimplating taking apart on of my non sport seats and useing those parts to fix it, of just save myself the trouble and buying a new one. and is the sensor near the fog light/ fake air intake?

Bear
05-05-2006, 09:18 AM
you could do just that as long as the connection is good. Sport Seats, maybe try Ebay or go to roadfly.com, E30 message board and ask there as they have a lot of folks looking at that website.

Bear
05-05-2006, 09:21 AM
mea culpa, the sensor is in the black plastic air dam near fog light. You can see the hole it sits in in the air dam. Sensor has a long dolphin like nose and most have a yellow plastc base at the connector. Get her in the air and slide under, maybe the connection is just separated.

Add your comment to this topic!