Cruise Control not working


Phil0968
04-12-2006, 12:58 AM
Alright guys i have a question for you as far as the cruise control goes on a 1993 J30 with 160K miles on it. I have owned the car for awhile now and the cruise control has never worked, when i push the button on the inside of the car the light comes on saying the cruise control is engaged but when i let off the gas the car decellerates meaning the cruise control isnt engaged at all. What is causing this and what can i do to fix it? Thanks guys

swimshark
04-12-2006, 11:08 PM
are you pressing the button for cruise control on the dash and the set cruise on the steering wheel? you have to press both to set the cruise. there are also 2 more buttons: one to cancel set cruise speed and one to speed up the acceleration.

cshiremath
04-15-2006, 04:11 PM
Alright guys i have a question for you as far as the cruise control goes on a 1993 J30 with 160K miles on it. I have owned the car for awhile now and the cruise control has never worked, when i push the button on the inside of the car the light comes on saying the cruise control is engaged but when i let off the gas the car decellerates meaning the cruise control isnt engaged at all. What is causing this and what can i do to fix it? Thanks guys

I have the same problem with my 1994 J30 with 240000 miles nad still running good. Did you get it fixed yet or find out what the problem is? Please post

Phil0968
05-01-2006, 02:06 AM
are you pressing the button for cruise control on the dash and the set cruise on the steering wheel? you have to press both to set the cruise. there are also 2 more buttons: one to cancel set cruise speed and one to speed up the acceleration.

ya ive done both the only thing that comes on is the light on the button in the dash, the buttons on the steering wheel have zero effect. I am going to have it looked at when i take it in to get my AC compressor replaced.

swimshark
05-03-2006, 11:11 PM
might be your lines have a loose connection

djnando
09-09-2006, 05:02 PM
HI i was just reading ur msg and i was wondering if were able to find the problem with the cruise control my is acting the same way.
light come on but will not hold the speed!
Hope to hear from u soon!

Add your comment to this topic!